ART & FILM DIRECTOR™
Instruction Manual
Art & Film Director
for the Apple II GS®
Credits

Epyx® and Art & Film Director™ are trademarks of Epyx, Inc. Paintworks Plus™ and Paintworks Gold™ are trademarks of Activision, Inc. Apple IIgs® and AppleTalk® are trademarks of Apple Computer, Inc. Deluxe Paint® II is a trademark of Electronic Arts.

Art & Film Director software was designed and programmed by Caesar Studio, produced by Software & Video Arts, Inc., and licensed from Novotrade Software Studios (Budapest, London, Los Altos). Artwork by Amanda Dee, Jeff Dee, Sheryl Knowles, Janet Kramer, and Matthew Sarconi with special acknowledgement to Maurice Molyneaux.

Art & Film Director manual was written by Epyx, Inc. Screen illustrations by Neil Hanshaw, Eric Lindstrom, and Epyx, Inc. Reproduction of all or any portion of this manual is not allowed without the specific written permission of Epyx, Inc.

Important Information

Epyx, Inc. warrants to the original purchaser of this Epyx software product that the medium on which this computer program is recorded is free from defects in materials and workmanship for a period of ninety (90) days from the date of purchase. This Epyx software program is sold "as is," that is, without express or implied warranty of any kind, and Epyx is not liable for any losses or damages of any kind resulting from use of this program. Epyx agrees for a period of ninety (90) days to either repair or replace, at its option, free of charge, any Epyx software product, postage paid, with proof of date of purchase, at its Factory Service Center.

This warranty is not applicable to normal wear and tear. This warranty shall not be applicable and shall be void if the defect in the Epyx software product has arisen through abuse, unreasonable use, mistreatment, or neglect. This warranty is in lieu of all other express warranties and no other representation or claims of any nature shall be binding on or obligate Epyx. Any implied warranties applicable to this software product, including warranties of merchantability and fitness for a particular purpose, are limited to the ninety (90) day period described above. In no event will Epyx be liable for any special, incidental, or consequential damage resulting from possession, use, or malfunction of this Epyx software product.

Some states do not allow limitations on how long an implied warranty lasts and/or exclusions or limitations of liability may not apply to you. This warranty gives you specific legal rights, and you may also have other rights which vary from state to state.

Epyx

600 Galveston Drive • Redwood City, CA 94063 • (415) 366-0606
Customer Service Bulletin Board: (415) 364-0281 • 300/1200 Baud • 8 Bits • No Parity • 1 Stop Bit

© 1988 by Epyx, Inc. All rights reserved.
# CONTENTS

INTRODUCTION ................................................................................. 1
   Welcome to Art & Film Director! ................................................. 1
      Art Director ........................................................................... 1
      Film Director ....................................................................... 2
Using This Manual ..................................................................... 2
Getting Started ......................................................................... 3
   System Components .................................................................. 3
   Art & Film Director Disk Contents ......................................... 3
      Copying the Disks .................................................................. 3
      Data Disks ............................................................................ 4
   Loading the Programs .............................................................. 4
   Program Controls ................................................................. 5
      Mouse .................................................................................. 5
      Keyboard ............................................................................ 5

USING ART DIRECTOR ..................................................................... 7
   Art Director Screen Components ............................................ 7
   Art Director Learning Session ................................................ 9

ART DIRECTOR REFERENCE .............................................................. 19
   Toolbox ................................................................................. 19
      Zoom Box ........................................................................... 19
      Pencil .................................................................................. 20
      Brush .................................................................................. 21
      Freehand ............................................................................ 24
      Line-Draw ........................................................................... 25
      Scissors .............................................................................. 26
      Bucket ................................................................................ 28
      Eraser ................................................................................ 29
      Text .................................................................................... 29
      Undo .................................................................................... 31
      Display .............................................................................. 31
Special Menu Options ........................................... 51
Use Brush Color ............................................... 51
Copy Palette ...................................................... 52
Palette Editor .................................................... 52
Cycle Color ..................................................... 55
Border Color ..................................................... 55
New Picture ...................................................... 55
Resize Picture .................................................... 55
Copy Picture ..................................................... 56
Show Picture ..................................................... 56
Warnings .......................................................... 56
Using Art.Show .................................................. 57
Creating Art for Film Director ............................... 57

ART DIRECTOR KEYBOARD SHORTCUTS ...................... 59
General Use ...................................................... 59
File Menu .......................................................... 59
Effects Menu ...................................................... 60
Tools Menu ........................................................ 60
Special Menu ..................................................... 61

USING FILM DIRECTOR ........................................ 63
Film Director Demonstration Film ......................... 65
Watching the Demonstration Film ......................... 65
Patterns ............................................................ 67
Polygons ........................................................... 69
Groups ............................................................. 70
Actors ............................................................... 70
Stages ............................................................... 70
Frames .............................................................. 71
Film Director Learning Session ............................ 72
Creating an Animated Film ................................ 72
Loading Pictures ............................................... 72
Cutting Out Patterns ......................................... 74
Making Polygons ............................................... 76
Forming Groups ........................................ 78
Animating Actors ..................................... 80
Laying Out Stages .................................... 81
Creating Frames ...................................... 82
Saving Your Film ..................................... 83

**FILM DIRECTOR REFERENCE** .......................... 85
  Message .................................................. 85
  Cursor Coordinates (H,V) ............................. 85
  Toolbox .................................................. 85
  Animation Board ...................................... 86
  *Film Director* Menu Bar .............................. 86
    Apple Menu Options ................................ 87
      About ................................................. 87
      Desk Accessories .................................. 87
    File Menu Options (Edit Mode) .................. 87
      Load Film ........................................... 88
      Save Film ........................................... 88
      Load Music ......................................... 88
      Save Screen ........................................ 88
      Save Preferences .................................. 88
      Delete File ......................................... 89
      Quit .................................................. 89
    File Menu Options (Design Mode) ............... 89
      Load Script ........................................ 89
      Load Picture ....................................... 90
      Save Script ........................................ 90
      Save Picture ....................................... 90
    Edit Menu Options .................................. 90
      Frames ............................................... 91
      Sequence ........................................... 95
      Designer ............................................ 98
    Design Menu Options ............................... 99
      Patterns ............................................ 99
      Polygons ............................................ 102
INTRODUCTION

Welcome to Art & Film Director!

Art & Film Director is a powerful, full-color, graphics and animation software package brought to you by Epyx. In this package you receive two programs—Art Director and Film Director. With Art Director you'll create beautiful characters, scenes, and storyboards. Then add "life" to your creations with Film Director, using techniques similar to those used in famous animated films. Finally, put your animated films on video tape to enjoy with your family and friends.

If you're serious about the exciting field of computer art and animation, or if you just want to have fun, Art & Film Director is the graphics and animation package for you!

Art Director

The Art Director program supplies you with a large canvas, a toolbox of artist's equipment, and a menu bar of options to help you make your painting "picture perfect." You can use up to 16 of the computer's 4,096 colors in each painting. With color cycling, you can use up to 256 colors!

Art Director is easy to use. Drawing tools let you paint in broad strokes or finely adjust a delicate line. You can create perfect shapes and fill areas with brilliant color with just a few mouse or keyboard moves.

In addition, the program is loaded with special features. For example, you can make an image look three-dimensional, wrap it around a cylinder, or change its perspective to send it traveling into a distant sunset!

Here are just some of the features you'll find in Art Director:

• Drawing pencil with a wide selection of points in different sizes and shapes.
• Paintbrush that you can make from any part of your painting, then easily duplicate, modify, flip in any direction, and use to fill other images.
• Shape tools for drawing perfect circles and squares as well as rectangles, ovals, and polygons.
• Choose from 4,096 brilliant colors to build your palette.
• Palette options that let you easily modify colors to achieve lighter and darker shades.
• Multiple canvasses that you can use at the same time—for example, to swap or duplicate colors and images.
• Images can be imported from Paintworks Plus/Paintworks Gold and Deluxe Paint II and used just like original Art Director images.

**Film Director**

The Film Director program offers you the latest in modern electronic animation techniques. Using Film Director, you can easily assemble images into animated art pieces that move lifelike around the screen. Film Director provides you with toolboxes and menu options so the features you need are always just a keystroke or mouse move away.

Here are some of Film Director’s features:

• Imports and animates Art Director images.

• Includes a graphics disk with art that can be assembled into animated figures and backgrounds.

• Supplies animation shortcuts that let you set the beginning and end of an action, then create all the poses in between.

• Lets you add text to your scenes.

• Includes files of sound effects for adding a musical dimension to your film.

**Using This Manual**

The Art & Film Director manual contains complete information on using both Art Director and Film Director. Following this introduction you’ll find a section on hardware requirements, loading instructions, and computer controls for both programs.

The Art Director section begins with a hands-on learning session. Here you work with the program’s most frequently used features to create a complete picture on your canvas. A reference section follows, containing detailed information about every Art Director feature, including the keyboard alternatives to mouse commands.

The Film Director section provides an overview and a learning session in which you become familiar with the program’s features while creating an animated figure. The reference section that follows provides detailed information on Film Director’s animation tools and menu options, including how to import and use images created in Art Director and how to video-tape your films. A listing of keyboard alternatives to mouse commands ends the section.

You can learn how to use Art & Film Director easily and quickly by reading this manual and experimenting on your computer. Work through the learning sessions from beginning to end. They’re designed to teach you how to create images in Art Director and animate them in Film Director. Practice using the tools and options, and don’t be afraid to experiment!
Getting Started

System Components

You’ll need these components in your computer system to use Art & Film Director:

- Apple IIGS computer with mouse
- 3 1/2-inch double-sided floppy disk drive
- Second floppy disk drive or hard disk drive (optional)
- Apple IIGS-compatible printer (optional)

To video-tape your Film Director films, you’ll need these additional components:

- Video cassette recorder (VCR)
- Computer to VCR cabling

For instructions on connecting your VCR to your computer, see Taping Your Art and Films in this manual.

Art & Film Director Disk Contents

You receive three disks—one Art Director disk, one Film Director disk, and one graphics disk—in your Art & Film Director package.

Your Art Director disk contains the Art Director program file ArtDirector. It also contains the file Art.Show, which lets you run a slideshow of your paintings.

Your Film Director disk contains the Film Director program FilmDirector. Use the program Music.Selector and the sound files Music.1, Music.2, and Music.3 to add sound effects to your animated films. The program Film.Show lets you show your films.

The graphics disk contains sample pictures and films. Use the graphics images as models or practice pictures, or copy these images to augment your own artwork. You can even load pictures from Paintworks Plus/Paintworks Gold and Deluxe Paint II into Art Director. Load in the sample films to modify while learning how to use Film Director.

Note: The screen illustrations in this manual are intended to represent actual Art & Film Director screens. However, certain screen components or filenames may differ from those you see on screen when running the programs.

Copying the Disks

For your convenience, the Art & Film Director disks are not copy-protected. As the owner of the software, you are encouraged to make backup copies of these disks for your personal use. Making and using backup copies protects you from accidentally erasing the original program disks.
To avoid confusion later, label and date your backup disks as soon as you make the copies. Consult your Apple IIgs computer manual for full instructions on copying disks.

If you have a hard disk drive connected to your system, you can set up an Art & Film Director directory (folder) on it and copy the floppy disk files to that directory. Then you can run the programs from your hard disk and easily save your paintings and animations. Any printer drivers you intend to use must be in the Drivers folder within the System folder of your hard disk's root directory, not in the Art & Film Director folder. Refer to the manuals supplied with your computer and hard disk drive for complete instructions.

After copying the original disks, store them in a protected place. That way, the programs and supporting files will remain safe and available. Always use your backup copies as your working disks.

Art & Film Director is protected by the copyright laws pertaining to computer software. This means that copying the program disks for any reason other than an owner's personal use and backup purposes is illegal. Epyx, Inc. appreciates your consideration in copying the disks for your personal use only, and not to share. This ensures our ability to continue to produce high-quality software for you.

**Data Disks**

If you're running Art & Film Director from floppy disks, you'll want to have several blank, formatted disks on hand for saving your work. It's a good idea to format these data disks beforehand, although Art Director includes a disk-formatting option for your convenience.

**Loading the Programs**

Follow these steps to load Art Director and Film Director from a floppy disk:

1. Set up your computer system, following the instructions in your computer manual.

2. Insert either your Art Director disk or your Film Director disk, label side up, into your startup drive.

3. Turn on your system. After a moment, the program launcher appears.

4. A directory window opens for your disk. Double-click on the Art.Director or Film.Director icon, depending on which disk is in the drive.

5. After a moment, the title screen appears as the program loads. When loading is complete, the program's main screen appears. You're now ready to use either Art Director or Film Director.
Program Controls

Mouse

With *Art & Film Director*, you use a mouse to draw and manipulate graphics and select options. When you roll the mouse on a flat surface, a cursor on screen follows the mouse’s movements.

Press the mouse button once to select tools, colors, and menu items and to draw, paint, and select images on your canvas. Sometimes you can press the mouse button again and see further information about a selected item.

The terms "click" and "double-click" are used throughout this manual to indicate when you should press the mouse button. The term "double-click" means two firm, quick clicks on the mouse button.

Keyboard

You can also operate *Art & Film Director* from your keyboard. While your cursor is on the active window, press one of the four Arrow keys to move the cursor one pixel in the arrow’s direction. (A pixel is an individual screen dot.) Hold down the Option key and press an Arrow key to move the cursor eight pixels in the arrow’s direction.

To access the computer’s control panel, position your cursor anywhere on the menu bar at the top of the screen, hold down the Open Apple and Control keys, and press Esc. Complete information about the control panel can be found in your Apple IIGS computer manual.

The Open Apple key activates specific commands in combination with other keys. These commands are listed next to their selections in the appropriate menu. Certain other key combinations also activate commands. See the Keyboard Shortcuts sections in this manual for complete details.
USING ART DIRECTOR

Art Director Screen Components

During loading, the Art Director title screen is displayed. When the program is finished loading, its main screen appears. This is where you create your Art Director paintings.

- **Menu Bar**: The menu bar contains five selections, each having a drop-down menu of options.
- **Toolbox**: The toolbox contains your painting tools.
- **Zoom Box**: The zoom box can be used to magnify the canvas area where your cursor is positioned. It also lets you select from eight levels of magnification for detail-editing your painting.
- **Tools**: Use the tools to draw, create shapes, brush on color and patterns, fill areas with color, cut out images, and add text to your picture. The tool that's highlighted is the one that's currently selected. You will use many of the tools in the Art Director Learning Session, next in this manual. Complete details about all tools are given in the Art Director Reference section.
Cursor Coordinates (H,V) When displayed, the cursor coordinates tell you the location of your cursor in pixels from the upper left corner of the canvas. Pixels are individual screen dots. The pixel in the upper left corner of the canvas is 0,0. On the largest possible canvas, the pixel in the lower right corner is 319,199.

Color Swatch The color swatch shows the color you selected from the palette and are now using on the canvas.

Palette The palette shows the 16 colors currently available for painting on the canvas. You can change the palette colors at any time.

Your picture is drawn on a canvas that can be as large as your computer screen. You view a portion of your canvas through the window. Here’s a description of the components of your Art Director window.

Canvas The canvas is where you draw, paint, manipulate picture sections, and place text. Your painting is created on the canvas.

Window The window lets you see a portion of your canvas. The canvas can be scrolled through the window so you can access any part of your canvas. Certain functions that affect a large area can be limited to the part of the painting visible in the window.

Close Box The close box deletes your current canvas.

Title Bar The title bar is a border running across the top of your window. It displays the title of your painting. The blank window at the start of the program is called NoName0. To move a window, place the cursor on the title bar, hold down the mouse button, and drag the window anywhere on the screen. Release the mouse button when the window is where you want it.
Full-Screen Box  Clicking in the full-screen box expands your window to its maximum size to fill the screen. The menu bar and scroll bars remain visible (covering a small portion of your canvas) and usable in this full-screen mode. Clicking in the box again returns your window to its original size and position.

Size Box  The size box lets you increase or decrease the size of your window. With your cursor on the size box, hold down the mouse button and move the mouse up and to the left to reduce the amount of canvas displayed, or down and to the right to increase the amount of canvas displayed.

Scroll Bars. The scroll bars let you view different parts of your canvas through your active window. Click on any of the four arrows, up, down, right, or left, to scroll your canvas. You can also position the cursor on the box in a scroll bar, press the mouse button, drag the box to a new position, and release the mouse button to change your view.

When you have more than one painting in memory, the windows overlap each other as though stacked. The window on the top is called the active window, and the canvas it reveals is the only one you can work on. If you want to work on a different canvas, move the cursor off your active window and position it on the edge of the window you want. Click the mouse button. The window you selected appears on the top of the stack to become your active window.

When you load *Art Director*, the pencil and freehand tools are highlighted. This means they are selected and ready to use.

Look at the menu bar at the top of the screen. Each of its five selections has a list (menu) of options that you can use to work on your paintings. Some of the menu options are used in the *Art Director Learning Session*, next in this manual. Complete details about all menu options are included in the *Art Director Reference* section.

**Art Director** **Learning Session**

Creating a simple painting is the best way to acquaint yourself with the *Art Director* program. Follow the step-by-step instructions in this section to paint a tropical scene with a palm tree, grass huts, and mountains. This get-acquainted session will show you how easy *Art Director* is to use.

Tip: If you don't like something you draw on the screen, click on Undo in the toolbox before you do anything else. Undo will cancel the last thing you added to the canvas.

When you load *Art Director*, you are in Freehand Draw mode. The pencil ✏ and freehand ✏️ tools are selected (highlighted) in the toolbox and you can draw freely by rolling the mouse while holding down the mouse button.

Begin by drawing a palm tree. Select a color for the top of the palm tree by moving the cursor onto the darker of the two greens in the palette and clicking. A dot appears on your
color choice, showing that the color is selected. The color also appears in the color swatch. Then follow these steps:

1. Move the scroll bars so the lower left portion of your canvas is visible in the window.
2. Position the cursor near the center of the screen, slightly toward the left.
3. Press and hold down the mouse button.
4. Move the mouse to draw the palm fronds. A green line appears as you move the mouse.
5. Finish drawing the top of a palm tree. Make sure you close the outline so there are no gaps in it. Release the mouse button when the palm tree top is complete.

Now draw the palm tree trunk by following the steps:

1. Change your drawing color to brown by clicking on brown in the palette.
2. Draw a tree trunk beginning at the bottom of the green treetop. Again, make sure you draw a closed outline.
   
   Tip: The green of the treetop can be considered part of the closed outline.

3. When your tree trunk is finished, click on Display. This activates the zoom box at the top of the toolbox. Trace your pencil over the tree trunk without holding down the mouse button. Watch the magnified outline in the zoom box. If you see a gap in your outline, position it under the small white square in the center of the zoom box and click. This adds a pixel of brown to your picture. Close all the gaps in your tree trunk outline this way.
Tip: If you like, select green again and close up any gaps in your treetop as well. When you are done closing the gaps, you may wish to turn the Display tool off again by clicking on Display. Deactivating the zoom box increases the speed and control of your cursor.

Fill in the palm tree and its trunk. Here are the steps:

1. Position your cursor on Tools in the menu bar, hold down the mouse button, and drag your cursor down until you highlight Local/Global. Release the mouse button to select it. Click on Global in the selection box. Then click on OK or press Return. This puts the program in Global mode which lets you fill shapes not entirely contained in the window.

2. Select the green color you used to draw the treetop.

3. Select the bucket tool by moving the cursor onto it and clicking. Notice that if the Display tool is on, the message changes to Fill (area with color) and the freehand tool is no longer selected. When you move the cursor out of the toolbox, it becomes a bucket with a falling paint drop.

4. Move the bucket onto the treetop, make sure the paint drop is inside the outline, and click. The treetop fills with green.

Tip: If the palm tree top is not a completely closed outline, green will leak from it and flood the canvas. If that happens, click on Undo in the toolbox. Your treetop returns to its outline form. Turn on Display, inspect the outline in the zoom box, and close up any gaps. Then fill the treetop again.

5. Fill the tree trunk. Select brown from the palette, then use the bucket to fill the tree trunk, the same way you filled the treetop.

Use the special shapes features to add grass and sky to the drawing. Follow these steps:

1. Select light green from the palette.

2. Click on the line-draw tool to select it. Click on it again to make its selection box appear.

3. Click on the Straight selection, then click on OK or press Return. If the Display tool is on, notice that the message changes to Straight Line (first point).

4. Move your cursor (a pencil) to a point on the lower left edge of the canvas (somewhere between the center and the bottom) and click. A small green dot appears.

5. Move the pencil to the right. A green line begins to stretch across the canvas. When you reach the right edge of the window, click again. The line sets itself in place.
6. Move the horizontal scroll bar all the way to the right to reveal the right edge of your canvas. Draw another straight line starting where the first line ended and extending to the right edge of the canvas. Click to set the line. Now you have one continuous green line drawn all the way across your canvas.

7. Select the bucket, move it below the green line, and click the mouse. The grass area fills with bright green. Now move the horizontal scroll bar to view the left side of the canvas again.

![Image](image.png)

8. When you drew the line, you may have drawn it through your tree trunk. If so, fill that part with brown, using the pencil and either the freehand or line-draw tool. Be sure to select brown from the palette before drawing over the green line.

Tip: Turn Display on, then watch your zoom box to help you position the cursor. Turn Display off when you're finished.

Now add some mountains and sky to your scene. Follow the steps:

1. Position your cursor on Special in the menu bar, hold down your mouse button, and drag your cursor down until Palette Editor is highlighted. Release the mouse button to select it. The palette editor appears.
2. Click on the dark blue bar (4). An arrow appears, showing that the color is selected.

3. Move the cursor onto the RGB grid (RGB stands for Red Green Blue) and position it in column g, row 3. (Row 0 is the bottom row.) Click. The blue in the color bar and in the box next to the grid changes slightly.

4. In the same column (g), and counting from the bottom, click in row 4, then in row 5, and finally in row 6. Watch how the blue color changes. Then move the cursor to column b, row 4, and click. The blue color changes to a pine green.

5. Click on OK in the palette editor or press Return. The color appears in the palette, above the green you used for the treetop. The color also appears in the color swatch because the color is selected.

6. Add a mountain range to your picture. Move the vertical scroll bar up to reveal the upper left portion of your canvas. Draw a jagged outline for mountains all the way across the window. Move the horizontal scroll bar so you can draw the mountains all the way across your canvas. When the mountain line is finished, make sure there are no gaps, then fill it in.
7. Add a sky. Select sky blue from the palette, place the bucket anywhere in the black background, and click.

This picture looks a little barren without signs of civilization. Now's the time to add some grass shacks. Follow these steps:

1. Select the pencil and the color yellow.

2. Select the line-draw tool. Click on it again to see its selection box. Select Rectangle, then click on OK or press Return.

3. Adjust the scroll bars to show the grassy area to the right of the palm tree. Position the cursor above the grass where you want the upper left corner of the shack to be, and click to set the point. Move the cursor down and to the right. A rectangle stretches across the canvas. Extend the rectangle down to the grass and click to draw the box.

4. Click on the selected line-draw tool again and select Polygon.

5. Use this tool to draw a roof for your shack. Place the pencil a short distance above the center of the box, where you want the peak of your roof. Click to set the first point.

6. Move the pencil to a point a little bit to the right of the box's upper right corner. Click to set the second point.

7. Move the pencil straight to the left. You see the base and third side of a triangle form as you move to a point just left of the box's upper left corner. Click to set the next point. Click again without moving the mouse to finish your polygon. The pencil cursor reappears.
8. Fill the box and triangle with yellow. You now have a grass shack.

9. Give the shack a door by selecting brown and drawing a small rectangle inside the yellow rectangle. Fill the door rectangle.

Outline the shack so it shows up clearly on the picture. Here are the steps:

1. Move your cursor to Tools in the menu bar. While holding down the mouse button, move the cursor down the menu to highlight Outline, then release the mouse button to select it.

2. Brown should still be your selected color. Move the cursor (now an arrow) onto the yellow part of the grass shack and click. A thin brown outline is drawn around the shack.

There's not much civilization with just one shack. Here's where your brush comes in handy. Follow the steps to add more shacks:

1. Select the scissors in the toolbox. A warning box appears. Ignore the warning for now and click on OK or press Return. If Display is on, notice that Cut Rectangle appears in the message at the upper left corner of the screen.

2. Large crosshairs appear on the canvas. Move the center of the crosshairs to a point to the left of the roof and directly above the roof peak. Click to set the upper left corner of the rectangle.

3. A dot appears. Move the mouse down and to the right to extend a box completely around the shack. When the lower right corner of the box is where you want it, click to set the box.
4. You've created a brush that consists of the grass shack plus some background. Move the mouse and you see a duplicate shack moving across the canvas. Place the shack where you want it and click to stamp it on your picture. Do this as many times as you want, adding more shack groups to your scene.

5. Use the tools you're familiar with to clean up the scenery behind the duplicate shack.

   The village could use a welcoming billboard. Make one by following these steps:

1. Select the pencil and the line-draw tool with the Rectangle option. Select gray from the palette.

2. Draw and fill two gray boxes, one vertical and one horizontal, to make a billboard for your village.

![Image of billboard](image)

3. Click on the text \texttt{A} tool in the toolbox. When the warning box appears, click on OK or press \texttt{Return}.

4. Select red from the palette.

5. Move the cursor—a small flashing bracket—onto the upper left corner of the billboard. Begin typing "Welcome to Club Caribe." Press \texttt{Return} if you need more than one line to fit the words on the sign.

   \textbf{Tip:} Don't move the mouse while you are typing the text.

6. When you finish typing, click or press \texttt{Esc} to turn the text into a brush. Then click to stamp the text onto the billboard.
Congratulations! You've finished your first *Art Director* painting! To view the entire painting, press **Open Apple V**. Click the mouse button to return to the main screen.

To save your painting, insert a data disk into the disk drive. Move the cursor to **File** in the menu bar. In the **File** menu, select **Save Picture**. An item selector appears. If you have more than one disk drive, click on **Disk** to view the directories of your other drives. When you see the directory you want to save your picture to, type in the filename **Village**. Click on **Save** or press **Return**. Your picture will be saved to disk under the filename **Village**.
ART DIRECTOR REFERENCE

When the Art Director program is finished loading, its main screen appears. The main screen contains the features you use to create your paintings.

Toolbox

The toolbox contains the features you'll probably use most often with Art Director. To use a tool, position the cursor on the tool and click. The tool icon highlights to indicate that it is selected. For many of the tools, clicking again on the tool displays a selection box of the tool's options.

Zoom Box

When Display is turned on in the toolbox, the zoom box magnifies the area of the canvas where the cursor is positioned. Use the zoom box to do fine detail work or to determine the exact pixel position of the cursor.

The white square at the center of the zoom box marks the cursor's position on the canvas. You can move the cursor over an image on the canvas to see its color composition pixel by pixel in the zoom box. If you are using the pencil in freehand mode, you can color a single pixel on the canvas by positioning the pixel under the white square in the zoom box and clicking.
Double-click on the zoom box to see its selection box:

You may display part of your canvas in any one of the eight different levels of magnification listed. Make your selection and click on OK or press Return. A box appears on your canvas, showing what the visible canvas area will be at the magnification you selected.

Using your mouse, move the box over the area you want to magnify and click. A new window appears showing the magnified view of the canvas area you selected. Move the cursor onto the new window. The cursor becomes a box the size of a pixel on your magnified canvas. With the cursor in the zoom window and Display on, the zoom box shows the area in its non-magnified size.

While the canvas is magnified, you can easily place color on it pixel by pixel. You can work only with the pencil. The only selection you can make is to choose a different color from the palette, or select Undo. To remove the special zoom window and return to your canvas, click on its close box.

**Pencil**

The pencil draws freehand lines and figures, straight lines, and a variety of shapes including circles, rectangles, and polygons. Click on the pencil to select it.

To draw freehand, select the freehand tool along with the pencil and move the cursor over the canvas while holding down the mouse button. To draw straight lines and defined, regular shapes, select line-draw and the pencil.
Click on the pencil again to see its selection box:

**One-Size Shapes** These selections determine the size of your pencil point.

**Any-Size Shapes** These selections let you create shapes in any size. The filled shapes are drawn filled with color. The unfilled shapes are drawn as outlines.

Make your selection and click on OK or press Return. If you select a one-size shape, hold down the mouse button while moving the mouse to draw.

If you select an any-size shape, click on OK in the warning box that appears or press Return. Click anywhere on the canvas to set a point where your shape will begin. Then move the cursor to extend your shape to the size you want. Click. The shape appears, and you can move it wherever you want on the canvas. When the shape is positioned, click to stamp it. You can paint with the shape by holding down the mouse button while moving the mouse.

If you choose a one-size shape, your pencil retains your selection until you change it from the pencil selection box. If you choose an any-size shape, it replaces your brush. When you create a new brush, your pencil point returns to its default setting.

**Brush**

The brush is a tool you define by cutting out a block of color, an image, or a piece of text from your picture. Once you create a brush, you can paint with it in ways similar to using a real paintbrush.

Click on the brush in the toolbox. If no brush was previously selected, and if you have not yet defined an any-size pencil point, a default brush is provided for you.
Define a new brush by clipping a shape from your picture with the scissors. (See Scissors later in this reference section.) Click on the brush icon in the toolbox again to see its selection box:

Transp  With this selected, any parts of the brush that match the canvas's background color will be "transparent." When you move the brush, any colors on the canvas will show through the "transparent" brush sections.

Block  With this selected, the entire brush will be visible, including any brush sections that match the canvas's background color. Irregular brushes (cut out with the freehand selection from the scissors selection box) are placed on a rectangle of background color.

Silhouette  With this selected, the original brush becomes a silhouette of solid color, depending on the color selected in your palette. Any parts of the original brush that matched the canvas's background color will be transparent. Use the Silhouette selection to create shadows for images on your canvas.

Flip Hor  This selection flips the brush left to right.

Flip Ver  This selection flips the brush top to bottom.

Halve Hor  This selection reduces the width of your brush by half. Click on OK in the warning box or press Return. Select Halve Hor again to continue reducing your brush.

Halve Ver  This selection reduces the height of your brush by half. Click on OK in the warning box or press Return. Select Halve Ver again to continue reducing your brush.
Tip: Halving a brush eliminates every other row or column of pixels in the direction of the halving. Because of this, some detail may be lost, and doubling a halved brush will not restore it to its original look.

Double Hor  This selection doubles the width of your brush. Select Double Hor again to continue doubling your brush.

Double Ver  This selection doubles the height of your brush. Select Double Ver again to continue doubling your brush.

Tip: Doubling a brush duplicates every row or column of pixels in the direction of the doubling. Halving a doubled brush restores the brush to its original look.

Turn 90° Right  This selection rotates your brush 90 degrees to the right (clockwise).

Turn 90° Left  This selection rotates your brush 90 degrees to the left (counterclockwise).

Assimilate  This selection uses the colors in your current palette to change the colors of your brush. Assimilate is useful when your brush is taken from one canvas and brought onto another canvas with a different palette. After selecting Assimilate, click on OK in the warning box or press Return. The brush's new colors will be as close as possible to the original colors, depending on your palette.

For example, suppose you create a brush by clipping out a tire from the graphics picture AutoArt. When you load a second painting with a different palette, the "tire" brush is still active. But its colors are now taken from the current palette and are different from the palette colors in AutoArt. The tire looks strange because its colors aren't chosen correctly. Select Assimilate from the brush selection box. Art Director chooses colors from the new palette that are as close as possible to the tire's original colors, and recolors the tire.

Default Brush  This selection replaces your brush with the default brush. A warning box appears to alert you that the process is irreversible. Click on OK or press Return.

Make your selections and, if needed, click on OK or press Return. Move your brush around the canvas by moving your mouse. Click to stamp the brush in place, or hold down the mouse button while moving the mouse to paint with your brush across the canvas.
Freehand

Select the freehand tool when you want to draw freely on your canvas. With the freehand tool you can select either the pencil (for Freehand Draw), the brush (for Freehand Paint), or the eraser.

Tip: Freehand painting or drawing is much easier with Display off.

Click on freehand to select it, and click on it again to see its selection box:

![Image of freehand tool settings]

**Mirror H** and **Mirror V** These selections divide the canvas into two sections that mirror each other. Anything you add to one section simultaneously appears in a mirror position in the other section.

Select **On** to activate a mirror. Mirror H divides the canvas vertically; Mirror V divides it horizontally. The coordinates show where the canvas will be split. With both mirrors on, the canvas is divided into four quadrants.

Select **Off** to deactivate a mirror.

See **Cursor Coordinates** (H,V) later in this section for more information on cursor coordinates.

**Set Mirror Position?** Select **Yes** to modify the location of your mirrors. These new settings will remain as your default settings. Crosshairs appear. Move the mouse to move the crosshairs. These define your mirror quadrants. Click to set your mirror quadrants, and both mirrors will be activated. Draw in one quadrant and images appear simultaneously at vertical and horizontal mirror positions in the other quadrants.

24
Tip: The line-draw tool also can be used with the mirrors set.

Make your selections and click on OK or press Return.

Line-Draw

Line-draw lets you draw straight lines, circles, ovals, squares, rectangles, and other figures. Click on the line-draw icon to select it, and click again to see its selection box:

![Line-draw tool selection box]

**Straight** This selection draws a straight line between two points. To use Straight on your picture, position the cursor where you want one end of the line and click to set the point. Move the cursor to where you want the line to end. Click again. A line is set between the two points.

**Zigzag** This selection draws a series of connected straight lines. To use Zigzag on your picture, position the cursor where you want the first line to start. Click to set the point. Move the cursor to where you want the first line to end and the second line to start. Click to set that point, then move the cursor to the third point. Continue until your figure is complete, then double-click to set it.

**Rays** This selection draws lines outward from a central point. To use Rays on your picture, position the cursor, then click to set the central point. Move the cursor to where you want the first line to end and click again. Next, move the cursor to where you want your second line to end and click. Repeat to draw as many rays from the central point as you want. When your figure is complete, double-click to set it.
**Polygon**  This selection draws multi-sided, multi-angled figures. To use Polygon on your picture, move the cursor to where you want the first point and click to set the point. Then move the cursor to the second point and click. A straight line appears. Move the cursor to the third point. Two lines follow the cursor. One line is connected to the last point set and the other is connected to the first point set. Click to set the third point. Continue setting as many points as you want. When your figure is complete, double-click to set it.

**Square**  This selection draws squares. To use Square on your picture, position the cursor where you want the upper left corner of the square. Click to set the corner. Move the cursor down and to the right. A box expands as you move the cursor. When the square is the size you want, click to set it.

**Rectangle**  This selection draws rectangles. To use Rectangle on your picture, position the cursor where you want the upper left corner of the rectangle. Click to set the corner. Move the cursor down and to the right. A box expands as you move the cursor. When the rectangle is the size and shape you want, click to set it.

**Circle**  This selection draws circles. To use Circle on your picture, position the cursor where you want the center of the circle and click. Then move the cursor in any direction. A circle expands as the cursor moves, centered on your first point. When the circle is the size you want, click to set it.

**Oval**  This selection draws ovals. To use Oval on your picture, position the cursor where you want the center of the oval and click. Then move the cursor in any direction. An oval changes shape in response to the cursor movement, centered on your first point. When the oval is the size and shape you want, click to set it.

Make your selection, then click on OK or press Return. Now you can use your selection on the canvas.

Tip: Select Undo from the toolbox before setting your last point to undo what you've drawn and start over.

You must draw your figure entirely within your current window. If you want to draw a larger figure, click on the full-screen box in the upper right corner of the window to expand your window to its maximum size.

**Scissors**

The scissors tool defines a brush by cutting out an image from the canvas. Your image becomes a brush which can be used with the same tools available for the pencil.

Click on the scissors tool to select it. Click on OK in the warning box that appears or press Return. Click again on the scissors tool to see its selection box.
**Art Director**

![Image of the Art Director interface](image)

**Rectangle**  This selection cuts out a rectangular section from the canvas. Position the crosshairs at the upper left corner of the image you want to cut out and click. A dot appears. Move the cursor to the lower right of your image. When the image is surrounded by an outline, click to cut out the image.

**Freehand**  This selection lets you trace around an image in freehand in order to cut out an irregular shape. Turn on Display and use the zoom box with this selection to see exactly where you're cutting. Hold down the mouse button and move the mouse to draw a line. When the line completely surrounds your image, release the mouse button to cut out the image.

**Oval**  This selection cuts out an oval section from the canvas. Position the cursor in the middle of the image and click to set the center of the oval. Move the mouse to expand the oval until it surrounds your image, then click to cut out the image.

**Pattern**  This selection is available after you've loaded the picture Fillpattern from your *Art & Film Director* graphics disk. The picture contains patterns that can be used to fill an area of your picture. On the canvas, move the cursor from pattern to pattern. When the cursor is on the pattern you want, click to cut the pattern out as your brush.

**Tip:** If the picture Fillpattern is not on your active canvas, you cannot use the Pattern selection.

Make your selections and click on OK or press Return. Now you can proceed to cut out your image using the scissors tool.
Bucket

Use the bucket to fill an area with color or with the image chosen as your brush.

To fill with color, select the bucket and the pencil from the toolbox and a color from the palette. Move the drop on the bucket cursor onto the area you want to fill and click. The area will fill with the selected color. If you've selected a special tip for your pencil, the area will fill with the shape of the tip.

To fill with a brush image, select the bucket and the brush from the toolbox. Move the drop on the bucket cursor onto the area you want to fill and click. The area fills with brush images.

Tip: Be sure the drop on the bucket cursor is inside the area you want to fill before clicking. Turn on Display and watch the zoom box for help if needed when positioning the drop.

If the area you want to fill is not entirely within the window, you must change to Global mode, otherwise the fill will stop at the edges of your window. (See Local/Global in the Special Menu Options section later in this manual.)

Select Undo from the toolbox to cancel the fill.

Click on the bucket to select it, and click again to see its selection box.

Area  This selection fills an area that is a single color and is completely enclosed by any other color or colors.

Suppose you have a section of canvas that is solid green. Draw a circle in that section, using blue. You can then fill the blue circle with any color, using Area.
Be sure the drop on the bucket cursor is on a green pixel within the blue circle before clicking to begin the fill.

If there are any gaps in the shape you are filling, so that the green on the inside of the circle is connected with the green on the outside, the fill color will "leak" out. When this happens, use Undo to cancel the fill. Color the gap using your pencil and another color, then refill the area.

Also, if any pixels of a color different from the color being filled occur in the area, they will not be filled. In the example above, if any red pixels occurred in the green fill area, they would not be affected by the fill color.

**Contour**  This selection fills an area enclosed by the color you are filling with. All pixels in the enclosed area will be filled, regardless of the color touched by the bucket's drop when you click to begin the fill.

For example, suppose you enclose the car in AutoArt in white rectangle. You can now fill that rectangle with white by using the Contour selection and clicking anywhere within the rectangle (making sure white is still the color selected in the palette). The fill continues until it meets the rectangle.

If any pixels of a different color occur in the white rectangle, the fill color will "leak" out. In that case, undo, fix the gap with white, and refill.

If you're using Contour to fill with a brush, select the color you want the fill to extend to as though you were filling with that color.

**Eraser**

Use the eraser to erase a portion of the canvas down to the background color. The eraser can be used with either the freehand, line-draw, or bucket tools. (See the section describing a tool for full information on using it.)

![Tip: The eraser wipes away all colors down to the background color. If you are drawing a figure in one color over something in another color, both colors will be erased when you use the eraser on them.](image)

Click on the eraser to select it, and click again to see its selection box. Click on the eraser size—Small, Medium, or Large—you want. Then click on OK or press Return.

![Tip: Any pencil point will act as an eraser when the background color is selected from the palette.](image)

**Text**

The text tool lets you add text to your picture. Once typed, the text becomes a brush which you can stamp anywhere on your picture.
Click on text in the toolbox. Move the cursor onto the canvas. The cursor appears as a small bracket. Begin typing. Your text appears in the color chosen from the palette. Press Return when you want to start a new line of text. Press Delete to delete the last character you typed.

When you finish typing, click or press Esc. The text becomes a brush. Position the text where you want it on the picture and click to set it.

Tip: Your text can be used exactly like any other brush, and is affected by your selections from the brush selection box. For example, selecting Halve Hor reduces the width of your text brush.

Click on text to select it, click again to see its selection box:

![Font Selection Dialog](image.png)

**Font Size** Select the font size you want to use. The Regular (8 x 8 pixels) font is always available. Make your selection and click on OK or press Return.

Other font sizes can be loaded from the *Art & Film Director* graphics disk. Follow these steps:

1. Insert the graphics disk into the disk drive.

2. Move the cursor to File in the menu bar to see its menu. (See File Menu Options later in this section for full information on the File menu.) Hold down the mouse button, move the cursor down the menu to highlight Load Picture (the first menu option), and release the mouse button.

3. An item selector appears, listing the files on the graphics disk.

4. Click on a font file (any file beginning with Font). Then click on Open. The file loads and the font appears on its own canvas.
5. Click on the edge of the window of the picture you want to type on to make it the active window.

6. Click on text in the toolbox to select it and again to see its selection box. You'll see that additional font sizes are now available to select and use in your pictures.

**Undo**

The Undo tool lets you cancel ("undo") the action you most recently performed on the canvas. To undo, click on Undo in the toolbox.

*Tip:* Only your last action will be canceled; you can't undo any actions before that. However, you can reverse your last Undo operation. Select Undo again. The former look of your picture will be restored.

**Display**

The Display tool toggles the zoom box, the cursor coordinates, and the message displays on and off. Click on Display in the toolbox to display these features. Click on the tool again to hide them.

*Tip:* Because many of your tools, including freehand draw, work more quickly when Display is off, you may want to do most of your drawing with Display turned off. Turn it on to do detail work with the zoom box, to determine the pixel location of your cursor, or to obtain information from the message below your canvas.

**Cursor Coordinates (H,V)**

When the Display tool is on, the cursor coordinates show the location of your cursor in pixels on the canvas. Pixels are individual screen dots, the smallest points of resolution on your picture.

The cursor coordinates H,V are relative to the upper left corner of the canvas, where H and V are both 0. H is the horizontal coordinate and increases as you move the cursor right. V is the vertical coordinate and increases as you move the cursor down.

The default and maximum canvas size is 320 pixels wide by 200 pixels deep. The pixel in the upper left corner is 0,0; the pixel in the lower right corner is 319,199. The window only shows a portion of the entire canvas at a time. The default window shows the upper left part of the canvas, from 0,0 to 249,142.

**Color Swatch**

The color swatch shows the color currently selected in the palette. Click on the color swatch to fill the entire canvas with its color. Then click on OK in the warning box that appears or press Return.
Tip: Clicking on the color swatch covers over any work on your canvas. If you click on the color swatch in error, click on Undo in the toolbox.

Palette

The palette shows the 16 colors currently available for painting and drawing on your canvas. You can change the palette colors at any time by using the palette editor and choosing from the computer's selection of 4,096 colors. (See Palette Editor in the Special Menu Options section later in this manual for detailed information on editing the palette.)

The color marked with the letter B (upper left corner of the palette) is the background color. The background color is the default color of the canvas, and other colors are applied over it.

Click on a color in the palette to select it. A dot appears on the color, indicating that it is selected, and the color appears in the color swatch. When you use a tool (except for the brush and eraser), the color you apply will be the currently selected palette color.

Tip: Another way to select a color is to position your tool over the color you want somewhere on your picture and press Control. This is especially useful when you have many similar colors in your palette.

Message

When Display is turned on, the message below the canvas tells you what tool you are using and often includes further information about that tool. When Art Director first loads, Display is turned off. Turn Display on to see your messages by clicking on Display in the toolbox. The message changes as you select different tools.
Art Director Menu Bar

The menu bar appears across the top of your screen. The menu bar contains five selections, each having a drop-down menu of options. You'll use the options both for working on your picture and for manipulating picture files.

Apple  The Apple menu contains an option that displays the program credits and version number. It also offers any desk accessories you may have. Consult your Apple IIGS computer manual for details on installing desk accessories.

File  The File menu includes options for loading, saving, deleting, and printing files, formatting data disks, and exiting the program. It also provides an option for saving your Art Director preferred settings.

Effects  The Effects menu contains options for manipulating a defined section of your picture. The image created by one of these options becomes a brush.

Tools  The Tools menu contains painting tools, such as the spray can and the outline option, that produce complex effects.

Special  The Special menu includes miscellaneous options both for controlling the color palette and for manipulating canvasses.

Move the cursor to any selection and press the mouse button to see a menu of options. Hold down the mouse button and move the cursor up and down a menu to highlight individual options. When an option is highlighted, release the mouse button to select it.

If you decide not to select any menu option, move the cursor outside the menu and release the mouse button. The menu disappears.
Apple Menu Options

The Apple menu contains the About option and any available desk accessories.

About

Select the About option to see the *Art Director* design credits and version number. Click on OK in the dialog box to return to your canvas.

Desk Accessories

Any desk accessories contained in the Desk Accessories folder inside the System folder of the disk you booted from will be available under the Apple selection. For more information on desk accessories, consult your computer manual.

File Menu Options

The File menu contains options for loading, saving, and deleting files, formatting data disks, printing files, and exiting *Art Director*. It also provides an option for saving the program preferences you set with *Art Director*.
Load Picture

The Load Picture option loads a picture. Select the option. An item selector appears listing the art files on the disk currently in the drive. These files can include paintings you've created and saved, text fonts, fill patterns, and clip art.

Click on a filename to select it, then click on Open or press Return to load the file. If the file directory is longer than one screen, click on the up and down scroll arrows at the top and bottom of the scroll bar to see all file selections.

To load a picture from a folder listed in the directory, double-click on the folder. The folder name appears on the directory line, and all the pictures and folders within it are listed in the directory. Click on a filename to select the file, then click on Open or press Return to load the file. If you do not want to load a file from that folder, click on Close. Your original file directory will be listed.
To load a picture from another disk, eject the disk currently in your disk drive, then insert the disk containing the file you want. Or, if you have more than one floppy drive, insert your disk into the second drive. Click on Disk in the selection box to see the directory of files on the new disk. Click on the filename to select it, then click on Open or press Return to load the file.

Select Cancel in the item selector if you don’t want to load a picture.

Tip: See your Apple IIGS owner’s manual for full information on using the computer’s item selector.

Save Picture

The Save Picture option saves the active canvas to disk as an Art Director file. When you select the option, the item selector appears. The name of your window is shown in the Save Picture box as the filename. If you want to save the picture under a different name, type a new filename for it using up to 15 characters. Click on Save or press Return. If you are saving to a file that already exists, click on Yes in the warning box that appears. Your picture will be saved to the disk.

Tip: The Save Picture option saves only the picture shown in the active window, and not all the pictures in memory. Those must be made active and saved in their own files.

To save your picture to another disk, eject the disk currently in your drive, then insert the disk you want to save to. Or, if you have more than one floppy drive, insert your disk into the second drive. Click on Disk in the selection box. The name of the disk you inserted appears in the directory line. Click on Save or press Return to save your picture to that disk.

To create a new folder, type a folder name in the Save picture box, then click on New Folder in the selection box. Your new folder appears in the file directory. To open an existing folder, double-click on the folder’s name, or click on the folder name, then click on Open. To close a folder, click on Close.

Save Preferences

Save Preferences saves the settings you chose with the Warnings option in the Special menu (warning boxes displayed or hidden) to disk. Before selecting Save Preferences, make sure the disk containing the Art Director program Art.Director is in the working drive. Then select Save Preferences.

An item selector appears. Check the listing to make sure Art.Director is in your current listing. (If it isn’t, return to the folder containing Art.Director.) Click on Save in the item selector or press Return. Your settings are saved in a file named A.Pre on the disk in your working drive. The next time you load Art.Director from that disk, those settings will be in effect.
Delete File

Select the Delete File option to erase a picture from a disk. The item selector appears. In the file directory, click on the filename of the unwanted file. When the filename is highlighted, click on Delete or press Return. In the warning box that appears, click on Delete again. The file will be deleted from the disk and cannot be retrieved.

Format Disk

The Format Disk option lets you format a disk without leaving Art Director. This is a great help when you want to save a picture but you don’t have a formatted disk handy.

Tip: Take care when using the Format Disk option. If a disk containing files is in the drive during formatting, all its information will be erased.

To format a disk, follow these steps:

1. Select Format Disk.

2. A dialog box appears. Eject your Art Director program disk and insert the disk you want to format, or insert it into a second floppy disk drive if you have one. Click on Disk in the dialog box. Type in a volume name for your new disk and click on OK.

3. A warning box appears. Click on OK.

4. The disk is formatted and you return to the canvas.

Choose Printer

Art Director can print your pictures to a printer provided you have the correct drivers for your printer. If you booted with Art Director, your printer driver must be in the Drivers folder within the System folder on the Art Director disk. When you select Choose Printer from the File menu, the Choose Printer selection box appears.

Printer Type A Printer Type item selector at the top of the selection box lists all the printer drivers included in the Drivers folder within the System folder on the disk you booted from. Click on the name of the printer that is connected to your computer.
Printer Port  The Printer Port item selector also appears in the selection box. Click on the port your printer is connected to on your computer.

Click on Direct Connect unless you are using AppleTalk. If you are using AppleTalk, refer to your AppleTalk manual for information on setup and configuration.

Click on OK or press Return to save your configuration to disk. If you rebooted with a disk that is no longer in the drive, you are prompted to place that disk in the drive and click on OK. (If your disk is write-protected, your configuration will be set in memory but will not be saved to disk.)

Page Setup
Select Page Setup to specify how you want your picture sized and oriented when it is printed. In the selection box that appears, the options available depend upon the printer you have. Make your selections and click on OK or press Return.

Print
Select the Print option when you want to print the picture in the active window. The selection box that appears lists options for choosing print quality, number of copies, paper source, and color or black-and-white printing.

Tip: The illustration above shows the selection box for an ImageWriter printer.
After making your selections, click on OK or press Return to begin printing.

Tip: Be sure you have your printer set up and ready to print before making your selections.

Quit

Select the Quit option to leave Art Director and return to your system desktop. A warning box asks if you're sure you want to quit. Click on Yes to leave the program and return to your desktop. Click on No to return to your canvas.

Effects Menu Options

The Effects menu contains options for manipulating a defined section of your canvas. When an option is selected, and Display is on, the option's name appears in the message section of your screen.

Images created by Effects menu options become brushes, and can be stamped repeatedly or painted onto your picture. They can also be modified with the options in the brush's selection box to create other effects.

For example, you can stretch an image with the Stretch option described in this section. The stretched image becomes a brush. By using a dark color from the palette and the Silhouette option from the brush's selection box, you can turn the stretched image into a shadow and stamp it near the original image for a shadow effect.
You must perform your effects entirely within your window. If you want to perform a large effect, click on the full-screen box in the upper right corner of the window to expand your window to its maximum size.

**Tip:** Some of the effects take several seconds to appear fully on your canvas. Press Esc to cancel an image that's being drawn by an Effects menu option.

**Rescale**

The Rescale option enlarges or shrinks a selected part of your painting and uses the resulting image as a brush. With Rescale you can change the size of an image but you cannot change its relative proportions.

Select Rescale. Click on OK in the warning box that appears or press Return. Crosshairs appear on your canvas. To create a rescaled brush, follow these steps:

1. Place the center of the crosshairs in the upper left corner of the area you want to rescale and click to set this point.

2. Move your mouse to see a box. As you continue moving the mouse, the box surrounds an area of your picture. Click when the box surrounds the area you want.

3. Crosshairs appear. Now set the image's new size. Move the crosshairs anywhere on your canvas. When you click, a dot appears and becomes the upper left corner of the new area. Move the mouse until the box is the size you want, then click. The image is reproduced in the new size and becomes your brush.

**Tip:** When setting the image's new size, move the mouse downward to create a normal image, upward to create an upside-down image, and to the left to create a flipped image.

4. Move your mouse to position the image, then click to stamp the image on your picture.

**Stretch**

The Stretch option alters the relative proportions of an image. For example, you would use Stretch on an image that is the correct scale for its surroundings, but you want it fatter or longer. With the Stretch option, the image you create becomes a brush.

Select Stretch. Click on OK in the warning box that appears or press Return. Crosshairs appear on your canvas. Then follow these steps:

1. Place the center of the crosshairs in the upper left corner of the area you want to stretch and click to set this point.

2. Move your mouse to see a rectangle. As you continue moving the mouse, the rectangle surrounds an area of your picture. Click when the rectangle surrounds the area you want.
3. Crosshairs appear. Now set the image's new size. Move the crosshairs anywhere on your canvas. When you click, a dot appears and becomes the upper left corner of the new area. Move the mouse until the rectangle is the size you want, then click. The image is redrawn in the new size and becomes your brush.

Tip: When setting the image's new size, move the mouse downward to create a normal image, upward to create an upside-down image, and to the left to create a flipped image.

4. Move your mouse to position the image, then click to stamp the image on your picture.

Distort

The Distort option lets you twist a portion of your picture into another shape. The image you create becomes a brush. With Distort, you can create interesting surrealistic images, shapes, and patterns.

Select Distort. Click on OK in the warning box that appears or press Return. A small arrow appears which you will use to define a four-sided shape. Follow these steps:

1. Decide on the area you want to distort, then outline it by setting points. Move the mouse to place the arrow on the first point of your outline. Click to set the point.

2. Move the mouse to extend a line between the two points. Click to set point two.

3. Move to a third point. The line becomes a three-sided shape. Click to set point three.

4. Move to a fourth point. A four-sided shape now defines the area that will be distorted. Click. The shape disappears.

5. Begin defining an area for the distorted image. Set four new points by moving the mouse and clicking, as in the previous steps. If you defined a regular shape, such as a square, for the source image (steps 1 through 4), you may want to set points for an irregular shape, such as a trapezoid, for the distorted image. You can even twist the image by defining an hourglass shape for the distorted image.

6. Once you set the fourth point, the image is redrawn in the distorted shape and is available as a brush.

Tip: When redrawn, an image will always begin at the first point you set. For example, suppose you set the first point of your source image at its upper left. Then you set the first point for the distorted image at its lower right. The image will be redrawn upside down and flipped left to right.
Rotate

The Rotate option turns a portion of your picture around an axis to the orientation you want. The image created with Rotate becomes a brush.

Use Rotate to create similar images with different orientations for use in *Film Director* animations. For example, Rotate can help you create images for an animation of an athlete swinging on a bar or a runaway tire rolling downhill.

Select Rotate. Click on OK in the warning box that appears or press Return. Crosshairs appear on your picture. Then follow these steps:

1. Place the center of the crosshairs in the upper left corner of the area you want to rotate and click to set this point.
2. Move your mouse to see a box. As you continue moving the mouse, the box surrounds an area of your picture. When the box surrounds the area you want, click to set it.
3. The rectangle appears in the center of the window with a line extending from its center toward the right side of the window.
4. Move the mouse to rotate the guide bar and box to the orientation you want for the redrawn image. When the guide bar points to the center right edge of the canvas, the image will be redrawn right side up. When the guide bar points to the center left edge, the image will be redrawn upside down and flipped left to right. When the guide bar and box are positioned the way you want them, click. The image will be redrawn as a brush that you can stamp or paint with on your picture.

Bend

The Bend option wraps a section of your painting around an imaginary cylinder. Use Bend to achieve a three-dimensional effect. For example, use Bend to wrap the word "soup" around a can, or make columns on the front of a building look cylindrical. The image created with the Bend option becomes your brush.

Select Bend. Click on OK in the warning box that appears or press Return. Crosshairs appear on your canvas. Follow these steps:

1. Place the center of the crosshairs at the upper left corner of the area you want to bend and click to set this point.
2. Move your mouse to see a box. As you continue moving the mouse, the box surrounds an area of your picture. Click when the box surrounds the area you want.
3. A small arrow appears. Move the arrow anywhere on the canvas and click to set the first point of the axis line for your imaginary cylinder.
4. Move the mouse to see a line stretch from the point you just set. This is the axis line of your cylinder. Click when the axis is positioned the way you want it.
5. When you move the mouse now, two curves appear, one at each end of the axis line. These curves represent the circumference of the imaginary cylinder. Move the mouse in any direction to size the curves. When the curves look good, click.

6. The image is redrawn, bent around the cylinder you defined, and becomes your brush.

Tip: The bending effect is very apparent when the bent area includes a pattern.

Bulge

The Bulge option wraps an image on or in an imaginary sphere. You can use Bulge to draw both a convex soccer ball and a concave reflection in a metal bowl.

Select Bulge. Click on OK in the warning box that appears or press Return. A small arrow appears. Now follow these steps:

1. Decide on the area you want to bulge, and move the arrow to its center. Click to set this center point.

2. A circle appears that you can expand and contract by moving the mouse. Expand this circle to enclose the desired area and click to set it.

3. A second circle appears inside the circumference. Move the mouse to expand or contract this circle. If you want the bulge to appear convex (like a ball), set the inner circle larger than its original size. If you want the bulge to appear concave (like the inside of a bowl), make the inner circle smaller than its original size. Click to set the inner circle.

Tip: You can't make the inner circle larger than the outer circle.

4. Art Director draws the bulge which becomes your new brush.

Tip: The bulge is very apparent when the bulged area includes a pattern.

Perspective

The Perspective option alters the perspective of a selected image. This option is useful for adding depth to a painting or creating a realistic scene such as railroad tracks heading into the distance.

Select the Perspective option. Click on OK in the warning box that appears or press Return. A dialog box appears asking if you want to set a new vanishing point. Click on Yes if you do. (Click on OK or press Return to retain a previously set vanishing point.)
Tip: The vanishing point is where converging lines in a painting appear to meet. Four lines appear radiating from a common vanishing point. Now follow these steps:

1. If you're setting a new vanishing point, move the mouse to position the vanishing point and click to set it. Crosshairs appear.

2. Define the image from your canvas that will have its perspective altered. Move the mouse to position the center of the crosshairs at the upper left corner of the image and click. When you move the mouse, a box appears. Move the mouse to size the box until it surrounds your image, then click to set it.

3. A line appears radiating from your vanishing point. The end of the line represents where the upper left corner of your source image will be drawn. Move your mouse until the line's end is where you want it, then click.

4. Move the mouse again. A triangle appears, representing the width of the final image. Adjust the triangle by moving your mouse, then click when the triangle is the size you want.

5. Move the mouse. A box appears, representing the height of the final image (that is, how far the image will reach from its end point, set in step 3, towards the vanishing point). Extend the image away from the vanishing point for normal perspective, or towards the vanishing point for a reversed image in perspective. Adjust the box to the depth you want and click to set it.

Tip: If you extend your perspective all the way to the vanishing point, nearly all of the original image will be condensed at the vanishing point.

6. The final image is drawn and becomes your brush.

**Tools Menu Options**

The Tools menu contains options that are used as painting tools, similar to the tools in the toolbox. Options from the Tools menu are used less frequently than toolbox tools, but produce more complex effects, such as color shading and outlining.
When you select an option, its name appears in the message at the bottom of the screen if Display is turned on. To exit from an option, select a toolbox feature or another option from the Effects or Tools menu.

**Spray Can**

The Spray Can option randomly sprays a mist of color on your picture. Using the Spray Can, you can create a starry sky, for example.

When you select this option, a selection box appears:
**Tool Size**  Your selection determines the size of your spray can nozzle when used with the pencil.

**Effect**  Your selection sets the rate at which color is sprayed as you move the nozzle over your picture. Select Slow for a fine mist; select Fast for heaviest coverage.

Make your selections and click on OK or press Return. If you’re using the pencil, a circle (the spray can nozzle) appears. Hold down the mouse button and move the mouse to spray. The color you spray will be the color currently showing in the color swatch.

If you’re using the brush, a box appears. Again, hold down the mouse button and move the mouse to spray. The result will be a spray of colors from the brush.

Tip: Holding down the mouse button without moving the mouse will eventually spray your brush on screen as though you stamped it.

**Scrape**

The Scrape option lets you scrape through an image on your active canvas to reveal an image from another canvas. When you’re creating frames for animation, use Scrape to achieve the effect of gradually revealing parts of another scene, or merging two scenes.

When you select Scrape, a selection box appears:

![Scrape Selection Box]

**Tool Type**  Choose Spray if you want to scrape away an image pixel by pixel for a misty effect. Choose Solid to scrape away an image in blocks. The Spray cursor is a circle; the Solid cursor is a box.

**Tool Size**  Select a size depending on the area you want to scrape away with each stroke.
Make your selections and click on OK or press Return. A selection box appears asking you to define the back picture containing the image you want to bring forth. Click on the window name, then click on OK or press Return.

Position the cursor on the area of your picture you want to scrape away. Then hold down the mouse button while moving the mouse to scrape. The underlying image from your back picture will be exposed in the scraped area.

When you are in Global mode (see Local/Global later in this section), scraping away at certain coordinates reveals an image from the same absolute coordinates on your back picture regardless of the window’s scroll bar settings. When you are in Local mode, the image you reveal comes from the same relative coordinates depending on how your scroll bars are set on both windows.

Tip: Scrape uses the palette of your front picture, and images from the back picture will be revealed in those colors. For best results, the palettes of both your front and back picture should be the same or at least similar.

**Melt**

The Melt option blends colors together. Select Melt and a selection box appears.

**Tool Size** Your selection determines the size of your melting tool.

Make your selection and click on OK or press Return. A box appears. Move the box to an area on your picture where two or more colors meet—for instance, where the top of a tree overhangs a roof. Then hold down the mouse button while moving the box over the area. Pixels of the different colors will change places within the area, achieving a drizzly look. In the case of a treetop overhanging a roof, the effect will be as if a breeze were blowing the leaves.
Shade

The Shade option sprinkles pixels of a darker or lighter shade onto a selected color in your painting. Select the option and a selection box appears:

![Shade option interface]

**Actual Color**  Your selection determines if the sprinkled pixels will be a shade darker or lighter than the color in the color swatch.

**Tool Size**  Your selection determines the size of your shading tool.

Make your selections and click on OK or press Return. A box appears. Move the cursor onto the palette and click on the color you want to shade. That color appears in the color swatch.

Move the cursor back onto the canvas, hold down the mouse button, and move the mouse. When the box moves over the color-swath color on your picture, pixels of color will be sprinkled onto it. The color sprinkled will be the color from your palette that is the closest shade (lighter or darker) to the actual color.

**Tip:** The Shade option does not create lighter or darker colors—it chooses them from the palette. For example, suppose the color in your color swatch is yellow, but there are no other lighter or darker yellows in the palette. When you use Shade, Art Director will sprinkle pixels of the closest color from the palette, such as brown, tan, or orange.
Xcolor

The Xcolor option substitutes or swaps one color of your picture for the color in the color swatch. Select the option and a selection box appears.

Replace  Select this option to substitute one color on the canvas for the color in the color swatch. For example, if you've painted a green house under a blue sky, use Replace to paint the house orange.

Exchange  Select this option to swap two colors on the canvas, so that each color replaces the other. For example, if you've painted an orange house under a blue sky, use Exchange to repaint the house blue and the sky orange.

Make your selection and click on OK or press Return. An arrow appears. Move the cursor onto the palette and click on a color. That color appears in the color swatch. Move the cursor back onto the canvas, place the point of the arrow on the color you want to affect, and click.

If you're replacing a color, the color in the color swatch will be substituted for the color pointed to. If you're exchanging colors, all occurrences on the canvas of the color in the color swatch and the color pointed to will swap places.

When you are in Global mode (see Local/Global later in this section), the Xcolor affects the entire picture. When you are in Local mode, only the part of the picture visible in the window is affected.

Color Merge

The Color Merge option merges a single color from one picture onto another. This option is helpful when you want to duplicate a one-color image, such as text, an outline, or a silhouette, from one canvas into the exact spot on another canvas.

Tip: Images copied with Color Merge are not brushes. They cannot be easily relocated on the second canvas once they are duplicated onto it.

Follow these steps:

1. Select Color Merge from the Tools menu. A selection box appears asking you to define the back picture containing the color you want to bring forth. Click on the window name, then click on OK or press Return.
2. Decide which color from the defined back picture you want to merge. Make sure your destination canvas is active, then click in the palette on the color in the same position as the color you want from the back picture. For example, if the image you want from the back picture is blue, and blue is in the second row, third column of its palette, select from the front picture palette the color in the second row, third column, no matter what that color is. Otherwise you won’t get the correct image.

Tip: Color Merge uses the palette of your front picture, and images from the back picture will be duplicated in those colors. For best results, the palettes of both your front and back pictures should be the same or at least similar.

3. Click anywhere on the canvas. The color from the back picture will be duplicated into the same location on the front picture, depending on your Tools mode. When you are in Global mode (see Local/Global later in this section), the color you merge comes from the same absolute coordinates on your back picture regardless of the window's scroll bar settings. When you are in Local mode, the color you merge comes from the same relative coordinates depending on how your scroll bars are set on both windows.

Outline

The Outline option outlines images in your picture with the color in the color swatch. Select an outline color from the palette. Move the arrow onto the color you want outlined and click. When you click, all shapes of that color will be outlined in the color selected in your palette.

When you are in Global mode (see Local/Global later in this section), the Outline affects the entire canvas. When you are in Local mode, only the part of the picture visible in the window is affected.
Tip: If you only want a certain object outlined, and there are other objects in the window of the same color, use the size-box on the window to resize it to enclose the image. Move the scroll bars to position the object inside the window. Make sure your canvas is in Local mode (see the Local/Global section below) and then perform your outline.

Local/Global
The Local/Global option lets you choose whether your Fill, XColor, Scrape, Outline, and Color Merge commands will affect your entire canvas (Global), or only the canvas area currently displayed (Local). In the dialog box that appears, click on OK or press Return. Refer to the description in this manual of the tool you're using to see specifically how Local/Global affects its use.

Tip: Clicking on the color swatch in the toolbox to flood the canvas with color will always flood the entire canvas regardless of this setting.

Special Menu Options
The Special menu contains miscellaneous options for controlling the colors of your canvasses and for manipulating whole pictures.

Use Brush Color
The Use Brush Color option is helpful when you're using a brush that you created on another picture having a different palette. Select Use Brush Color to change the current palette to the one that was originally used to create your brush.

Tip: This option will work even if the picture where your brush was originally created has been deleted.
Copy Palette

The Copy Palette option lets you change your palette to a palette from another picture. When the selection box appears, select the picture containing the palette you want to use in your current picture. Click on OK or press Return. The two pictures then have identical palettes.

Palette Editor

Select Palette Editor to modify the colors in any of the 16 palettes in your picture. Each palette contains 16 colors.

Paintbox  The colors shown in the paintbox are the colors currently in your palette. The colors are numbered as they appear in the palette from top to bottom. Colors 0 through 3 are in the far left column of the palette; colors 4 through 7 are in the center left column; colors 8 through 11 are in the center right column; and colors 12 through 15 are in the far right column. The arrow marks the color currently showing in the color mixer.

Color Mixer  Use the color mixer to modify the colors in your palette. You can change one color at a time in the color mixer. The color currently in the mixer is shown with its RGB value.

The RGB value is composed of three digits representing the red, green, and blue light intensities, in that order, of the color. The 16 brightness levels are numbered from 0 (least intense) to 15 (most intense). There are 4,096 RGB combinations (16 x 16 x 16 = 4,096) making 4,096 colors possible.
To change a color in the color mixer, click on the color in the paintbox you want to change. That color appears in the color mixer. Move the cursor onto an empty square in the RGB grid and click. The square will be highlighted and the color in the color bar will change, reflecting the new RGB value you just set. The same color in the paintbox will also change to the new color. When you return to the canvas, the new color appears in the palette in place of the original color.

Tip: Do not set colors 0 and 15 to the same RGB value. Color 15 is the background color, and color 0 is the outline and type color of the palette editor. If you set both colors to the same value, you will not be able to read the palette editor.

**Palette Selector** You can use up to 16 palettes per canvas to create color cycling. Color cycling scrolls colors from different palettes through the same image or images on a canvas, often creating the effect of motion.

In the palette selector, the palettes are labeled A through P. Click on a palette letter to select it. The letter of the palette currently selected is highlighted, and the colors of that palette appear in the paintbox.

**Color Cycle Timer** The color cycle timer lets you set up and activate color cycling. Follow the steps:

1. On your canvas, draw an image using palette A (your first color palette).
2. Select Palette Editor from the Special menu.
3. Click on B in the palette editor to select the second palette.
4. Modify the colors in the palette B paintbox. The colors you modify must be used in your painting in order for the effect to be seen.
5. Select palette C and modify the colors. Again, the colors you modify must be used in your painting in order for the effect to be seen.
6. Continue selecting palettes and modifying colors until you have all the palettes you want or you've used all 16 palettes.
7. Set the time each palette will remain on screen in a color cycle. To do that, click on the number in the color cycle timer that's below the palette letter. The number represents a relative time scale and may be set from 1 (fastest) to 9 (slowest). The number increases by one with each click. (A palette set at 0 is skipped during a color cycle.)
8. To preview your color cycling, hold down the mouse button on View Cycle in the palette editor. Release the mouse button to stop the preview.
To view your color cycling from the canvas, select the Cycle Color option from the Special menu. Click the mouse button to stop the color cycling. To view your color cycling while showing the entire picture, select the Show Picture option from the Special menu. Click the mouse button to return to your window.

**Copy**  This selection copies colors. The purpose of Copy is to copy colors within a palette, or to copy one palette to another. This is useful if you want to keep a copy of your current color or palette while you modify it.

To copy a color within the same palette, first click on the color in the paintbox that you want to copy. Then click on Copy. Finally, click on the color in the paintbox you want to copy over. The first color selected in the paintbox is copied over the second color. In the palette on the canvas, the first color selected appears in its original position and in the position of the second color selected.

To copy a palette, select a palette letter in the palette selector at the top of the palette editor. Then click on Copy. Finally, select a second palette letter in the palette selector. The colors in the first palette selected are copied to the second palette selected.

**Tip:** If you click on Copy in error, click on it again to deselect it.

**Swap**  This selection exchanges colors within a palette or from palette to palette. Doing this helps you to reorganize your palette. Swap is also helpful in rearranging the order of your palettes for color cycling, because the palettes with non-zero cycle times are displayed in order from A to P.

To exchange colors in the same palette, select one color from the paintbox. Then click on Swap. Move the cursor back to the paintbox and select a second color to exchange with the first color. The two colors will trade places in the paintbox.

To exchange the colors of two palettes, first select a palette letter in the palette selector. Then click on Swap. Finally, select a second palette letter. The colors of the two palettes will be swapped.

**Tip:** If you click on Swap in error, click on it again to deselect it.

**Invert**  When you click on this selection, it inverts all colors on the palette. Inverting a color changes it to its complementary color—one that has the opposite RGB value. (The new RGB value will be the old RGB value subtracted from 15,15,15.)

**View Color**  Hold down the mouse button on this selection to view your picture in the current palette colors. Release the mouse button to return to the palette editor.

**View Mono**  Hold down the mouse button on this selection to view your picture in shades of gray. Release the mouse button to return to the palette editor.
View Cycle  Hold down the mouse button on this selection to preview your color cycling. Release the mouse button to return to the palette editor.

Up/Down  Shifts all colors in the paintbox by one box, either up or down, depending on which selection you click on.

Undo  Click on this selection to cancel your last action in the palette editor.

Make your selections, then click on OK or press Return to return to the canvas.

**Cycle Color**

To view the color cycling of your picture through its window, select Cycle Color from the Special menu. Click the mouse button to stop the color cycling.

**Border Color**

The Border Color option lets you change the color of the border around your screen. Click on the color you want in the selection box, then click on OK or press Return.

**New Picture**

The New Picture option creates a new blank picture. When the selection box appears, type in a title for your new picture. The default size of your canvas is the maximum size, 320 x 200 pixels. If you want your canvas to be smaller, click on H size or V size and type in new values. The minimum canvas size is 100 x 39 pixels. When you are finished specifying your new canvas, click on OK or press Return. Your new canvas appears as the active window.

**Resize Picture**

The Resize Picture option lets you reset the size of your canvas. To change the size of your canvas, click on H size or V size and enter new values. The H setting must be between 99 and 321, while the V setting must be between 38 and 201. To change the name of your canvas, click on the name and type in a new one.

Tip: If you resize a canvas with graphics on it, your picture does not get rescaled. If you resize to a smaller canvas, parts of your picture on the left and bottom edges are deleted. If you resize to a larger canvas, empty areas are added to the left and bottom edges of your canvas.
Copy Picture

The Copy Picture option copies your current picture onto another existing picture. This option is handy when you want a backup copy of your current picture within easy reach. When the selection box appears, select the picture you want to replace with your current picture. Click on OK or press Return. Then click on OK in the warning box that appears or press Return. The two pictures, their palettes, and their names are then identical.

Tip: If you don’t want to overwrite an existing picture, create a new one with the New Picture option.

Show Picture

The Show Picture option displays your entire picture while cycling color. Click the mouse button to return to the default screen.

Warnings

The Warnings option lets you toggle various warning messages on and off. Select Warnings and a selection box appears:

![Warning Dialog]

**Picture Overwrite**  This message warns that you are about to write over an existing picture. It appears when you want to copy one picture onto another, or if you want to flood the picture with color by clicking on the color swatch in the toolbox.
Brush Overwrite This message warns that you are about to replace your brush with another brush. It appears if you choose an option that lets you create another brush.

Assimilate This message warns that assimilating a brush is irreversible. It appears when you select Assimilate from the brush tool selection box.

Quit This message warns that you are about to quit, and reminds you to save any changes you made to your picture before quitting. It appears when you select Quit from the File menu.

Set each selection to Off or On by clicking on either word. Off means the warning box will not appear during your Art Director session; On means the warning box will appear. Then select OK or press Return.

You can save your selections to disk with the Save Preferences option in the File menu.

Using Art.Show

Art.Show is a program that lets you display your Art Director paintings one by one in a slideshow. From your desktop, copy the file Art.Show, on your Art Director disk, to any disk containing art files. When you want to watch a slideshow of the pictures, insert the disk into a drive and select Art.Show from the directory line. The program will display all pictures on the disk, one at a time.

Tip: If your art files are in a folder, copy Art.Show into the folder with them. To watch the slideshow, run Art.Show from the folder.

Press Spacebar to pause the slideshow; press it again to resume. Press Esc to exit the program and return to the desktop.

Creating Art for Film Director

All the artwork you create in Art Director for animation in Film Director must be placed on the canvas in a special way. Two rules govern the placement of your images on the canvas:

Rule 1: Always place an individual image on the canvas so that a box can be drawn around it without any other images intruding inside that box.

Since you will define images in Film Director as rectangular areas, each image must be placed in its own rectangular area in order to be used separately. Keep at least one pixel separation between rectangular areas. If you have a rectangular area directly adjacent to another one, you might end up either missing part of your image or gaining part of the adjacent image when you transfer the image to Film Director.
Rule 2: You may want to take images from Art Director and place them in a vertical line in Film Director. To do that, you must position those images in a special way in Art Director. Find a point at the bottom of one image and at the top of the other image that will meet vertically when the images are lined up in Film Director. Those points must both be drawn in Art Director on the same kind of horizontal pixel (either even or odd), as indicated by the H coordinate.

For example, suppose you want to place a chimney on the roof of a house. The seam where the chimney and roof meet is seven pixels wide, horizontally. You can call the far left pixel on the seam pixel A. If pixel A on the bottom of the chimney is drawn on an even-numbered pixel, then pixel A on the top of the roof must also be drawn on an even-numbered pixel.

Tip: If your patterns don’t line up properly in Film Director, return to your Art Director canvas and load the art file containing your pattern picture. Select Block from the brush selection box. Cut out one of your images as a brush, move the brush one pixel left or right using an Arrow key, then click the mouse to stamp the brush. Save your picture. Run Film Director and load the altered picture. You may have to recut your pattern, since it was moved. It should now line up properly with the other pattern.
ART DIRECTOR
KEYBOARD SHORTCUTS

With Art Director, you can make selections from the keyboard instead of using your mouse. Press the following keys to select the option listed next to each key.

**General Use**

**Open Apple/Control/Esc** Displays control panel when cursor is on menu bar.

**Arrow keys** Move cursor one pixel in arrow's direction on active window.

**Open Apple Arrow keys** Move cursor eight pixels in arrow's direction on active window.

**Option** Constrains cursor to vertical movement when using the mouse.

**Shift** Constrains cursor to horizontal movement when using the mouse.

**Control** Picks up color from canvas.

**Open Apple Z** Undo.

**File Menu**

Press these keys to select options from the File menu.

**Open Apple L** Load Picture

**Open Apple S** Save Picture

**Open Apple F** Save Preferences

**Open Apple D** Delete File

**Open Apple R** Choose Printer

**Open Apple U** Page Setup

**Open Apple P** Print

**Open Apple Q** Quit
Effects Menu
Press these keys to select options from the Effects menu.

Open Apple 1  Rescale
Open Apple 2  Stretch
Open Apple 3  Distort
Open Apple 4  Rotate
Open Apple 5  Bend
Open Apple 6  Bulge
Open Apple 7  Perspective

Tools Menu
Press these keys to select options from the Tools menu.

Open Apple C  Spray Can
Open Apple A  Scrape
Open Apple M  Melt
Open Apple H  Shade
Open Apple X  Xcolor
Open Apple I  Color Merge
Open Apple O  Outline
Open Apple G  Local/Global
Special Menu

Press the following keys to select options from the Special menu.

- **Open Apple B**  
  Use Brush Color

- **Open Apple J**  
  Copy Palette

- **Open Apple E**  
  Palette Editor

- **Open Apple 9**  
  Cycle Color

- **Open Apple N**  
  Border Color

- **Open Apple W**  
  New Picture

- **Open Apple Y**  
  Resize Picture

- **Open Apple K**  
  Copy Picture

- **Open Apple V**  
  Show Picture

- **Open Apple T**  
  Warnings
USING FILM DIRECTOR

Film Director uses traditional animation techniques to assist you in creating your own films. The many time-saving features Film Director offers, together with the speed of the Apple IIgs, let you quickly assemble your artwork into colorful and exciting animated works. You can then transfer your films to video tape to use in many ways, from family fun to professional product presentations.

Film animators use a technique called cel animation to animate their artwork. A cel is a sheet of transparent celluloid with artwork painted on it. Celts are layered, or stacked, to assemble the frames that make up the completed film. Without a computer, the process of creating cels and assembling them into a film can be long and tedious. Film Director advances the concept of cel animation by having the computer generate many of the intermediate steps necessary to create smooth animation.

A film is a series of still pictures, called frames, that give the illusion of movement when viewed in rapid succession. Film Director's frames contain layers of cels that can be manipulated in many ways to speed the animation process.

Patterns are images cut out of art files from Art Director. They can be anything from small images to large blocks of color to body parts used in the construction of characters. The cut-out patterns can be used as cels in a frame. A special type of image, called a polygon, is a geometric line drawing created in Film Director.

Patterns and polygons can then be used to build a more complex cel, called a group. A group is a single cel that is constructed with multiple patterns and polygons. This is a useful element when you want to build an object out of many smaller graphics, but later want to treat the object as a single cel.

One of the most valuable animation tools Film Director offers is the actor. An actor is a series of cels that define an action when viewed in sequence. Each cel in the series is called a phase, and it can be a pattern, a polygon, or a group. Examples of actors are a person running, a wheel rolling, or a ball bouncing.

Using cels, you can design stages for your film. A stage is a backdrop placed behind the action in a film. Stages are used most often to provide scenery and other elements of the film that are stationary.

The range of Film Director's power is shown in its ability to create the intermediate elements in an animated sequence. This feature is called tweening. Suppose you want to show a child dropping a ball in a series of ten groups. All you have to create is the first group (the child holding the ball) and the last group (the ball on the ground). Then, when you select the Tween option and specify eight groups, Film Director creates the eight intermediate groups needed for the ball to appear to fall. The Tween option can be used to create intermediate polygons, groups, and stages.

Patterns, polygons, groups, actors, and stages are the elements used to create frames. You can construct frames one at a time, or work simultaneously on a number of frames that
are in sequence. For example, with one operation you can change the stage of a single frame or a sequence of frames in your film.

The record feature provides a way to add an actor to your film. With this feature you record your actor on existing frames. Do this one frame at a time, specifying the position of each phase in a frame.

Once you have an actor defined in your film, you can use the overlay feature to duplicate images in different locations. For example, you can quickly transform a single dancer performing a high kick into a chorus line. Then you can have the dancers kick in perfect synchronization or skew each dancer one frame to create a wave effect. You can also copy this sequence so the dance lasts as long as you want.

Add new cells to a sequence of frames by using the interpolate feature. This option tweens the elements in your film, but instead of creating new frames, it finds the intermediate images from your defined elements and places those cells on the existing frames. Interpolate is used for patterns, polygons, and groups.

Film Director also offers a layering feature. Layering places a cel under or over another cel. For example, by layering cells you can show a bird flying through the trees, passing in front of some trees and behind others.

You can save your work to disk at any time. When your film is complete you can even add sound effects from the music files included with Film Director.

When you're ready to begin creating a film, load the Film Director program. (For directions, see the Getting Started section earlier in this manual.)

During loading, the Film Director title screen is displayed. After the program finishes loading, its main screen appears. This is where you will begin putting together an animated film.
Here's a brief summary of the components of the Film Director screen:

**Toolbox** The toolbox contains tools for creating your films.

**Message** The message shows the option you most recently selected and often gives information about it. Blank Object is the message when you load Film Director.

**Animation Board** The animation board is where you create your film.

**Cursor Coordinates (H,V)** The cursor coordinates tell you the location of your cursor in pixels from the upper left corner of the animation board. They behave exactly the same as the cursor coordinates in Art Director.

Each of the four menu selections at the top of your screen has a menu (list) of options that you can use to work on your film. Some of the menu options are used in the *Film Director Learning Session*, next in this manual. Complete details about all menu options are included in the *Film Director Reference* section.

**Film Director Demonstration Film**

**Watching the Demonstration Film**

A demonstration film is provided on the Art & Film Director graphics disk so you can see some of the animation opportunities Film Director offers you. To watch the film, follow these steps:

1. Load *Film Director* as explained in *Getting Started*, earlier in this manual. When the main screen appears, eject the *Film Director* disk from the drive and insert the graphics disk.

2. Move the cursor onto the word File in the menu bar and press the mouse button to display its menu. Hold down the mouse button, move the cursor down to highlight Load Film (the first menu option), and release the mouse button.
3. The Load Film item selector appears, listing the film files on the disk.

Tip: You may be running Film Director with a second floppy disk drive connected to your system or from a hard disk drive. If so, click on Disk in the Load Film item selector so you can access your other drive. A new directory for the correct drive appears, listing the file Demo.Film.

4. Click on Demo.Film to select it. Then click on Open. The file loads and displays the first frame of the film.
5. Move the cursor to Options and press the mouse button to display its menu. Hold down the mouse button, move the cursor down to highlight Show Film (the last option), and release the mouse button.

6. A selection box appears offering direction and speed options. For now, click on OK. (The options are explained in the Show Film section, later in this manual.) The demonstration film begins playing.

7. Watch the film to see a fully animated sequence, complete with background details, created with Film Director.

8. Click at any time to stop the film and return to the animation board.

Patterns

When you loaded the demonstration film, you also loaded the graphic images—or patterns—that are the building blocks of an animated figure. To look at the patterns, load DemoFilm if you have not already done so, following the steps in the previous section. Then continue with these steps:

1. Move the cursor to Edit on the menu bar and select the Designer option from the menu.

![Blank Object](image)

The word "Design" replaces the word "Edit" in the menu bar, showing that you are now in Design mode.
2. Move the cursor to Design and select Patterns from the menu.

A screen of images appears. This is picture A, one of two pictures used to create the demonstration film Demo.Film. The screen also contains the Patterns toolbox and an arrow cursor or crosshairs, depending on the position of the cursor.

3. Move the cursor into the toolbox and click on the words "Picture A." Picture B appears. Demo.Film uses two pictures: picture A and picture B. Pictures A and B contain all the images needed to produce Demo.Film’s characters and props, in all their positions. The images are separate elements of the characters and props, and are drawn from every view and orientation needed for the film. These images can be cut out as patterns.
Pictures A and B were created with Art Director and saved as art files. Then they were loaded into Film Director, where the patterns were cut from pictures and used to create the demonstration film.

You can look at each pattern individually. Follow the steps:

1. Click on # in the toolbox's first row. The Select Pattern dialog box appears.

![Select Pattern dialog box](image)

2. In the dialog box, click on First. Pattern #1 appears on screen, surrounded by a flashing box. This pattern has been cut from picture A of Demo.Film.

3. Move the cursor to the toolbox and click repeatedly on the > character in <Step> in the second row. Patterns from Demo.Film will appear sequentially, one at a time. Or, hold down the mouse button while pointing to the > character. Patterns sequentially appear until you cycle through all the patterns used in the demonstration film.

**Polygons**

Polygons are another basic element used to create an animated film. To look at the polygons used in the demonstration film, follow the steps:

1. Look at the menu bar. You should be in Design mode, with Design as the third menu selection from the left. (If it isn't, display the Edit menu and select Designer.)

2. Select the Polygons option from the Design menu. The screen displays the Polygons toolbox and the first polygon in the polygon series in Demo.Film. Polygons are multi-sided shapes that can be used as elements in your animated film. You create polygons using tools from the Polygons toolbox.
3. Move the cursor into the toolbox and click repeatedly on the > character in <Step>. Polygons from Demo.Film will appear sequentially, one at a time. Or, hold down the mouse button while pointing to the > character. Polygons sequentially appear until you cycle through all the polygons used in the demonstration film.

**Groups**

Groups are collections of patterns and polygons. In Demo.Film, the parts of the boy are collected into groups to make up a complete boy figure.

To look at the groups, follow the steps:

1. Select Groups from the Design menu. (Groups is the third option from the top of the menu.) The screen displays the Groups toolbox and the first group in the group series in Demo.Film.

2. Move the cursor into the toolbox and click repeatedly on > in <Step>. Or, hold down the mouse button while pointing to >. Groups sequentially appear until you cycle through all the groups used in Demo.Film.

Groups are created with tools from the Groups toolbox. Once a group is defined, it can be used in your film.

**Actors**

An actor is a series of patterns, polygons, and/or groups. Each phase in the series is selected and arranged in such a way that when the series is viewed in rapid sequence, the actor appears to move. The boy riding his bicycle is an example of an actor.

To look at the actors in Demo.Film, follow the steps:

1. Select Actors from the Design menu. The screen displays the Actors toolbox and the first actor in the actor series in Demo.Film.

2. Move the cursor into the toolbox and click repeatedly on > in <Step>. Or, hold down the mouse button while pointing to >. Actors sequentially appear until you cycle through all the actors used in Demo.Film.

Actors are created with tools from the Actors toolbox. Once an actor is defined, it can be used in your film.

**Stages**

Stages are backgrounds in a film, giving it a feeling of place and atmosphere. Stages are composed of patterns, polygons, and groups, and sometimes contain text.
To see the stages used in the demonstration film, follow the steps:

1. Select Stages from the Design menu. The screen displays the Stages toolbox and the first stage used in Demo.Film.

2. Move the cursor into the toolbox and click repeatedly on > in <Step>. Or, hold down the mouse button while pointing to >. Stages sequentially appear until you cycle through all stages used in Demo.Film.

Stages are created with tools from the Stages toolbox. Once defined, stages can be used in your film.

Frames

The elements created with the Design feature—patterns, polygons, groups, actors, and stages—can be put together to create frames.

To look at all the frames that make up the demonstration film, follow the steps:

1. Look at the menu bar. You'll be using the Edit menu, so Edit should be the third menu selection from the left. If Design is the third selection from the left, move the cursor to it to display its menu, and then select the Editor option. Edit should now be the third menu selection from the left.

2. Select Frames (the first selection) from the Edit menu. The screen displays the Frames toolbox and a frame from Demo.Film.

3. Move the cursor into the toolbox and click repeatedly on > in <Step>. Or, hold down the mouse button while pointing to >. Frames sequentially appear until you cycle through all the frames used in the demonstration film.

As you view the frames, you'll see that each frame is only slightly different from the one before it. When the frames are viewed in rapid succession, they create the illusion of smooth, continuous movement. Notice that each frame is composed of elements—patterns, polygons, groups, actors, and stages—that were defined in Design mode.

Look at the demonstration film again, now that you have an idea of how it was produced. To view the film, select the Show Film option from the Options menu. Then click on OK in the dialog box that appears.
**Film Director** Learning Session

Creating an Animated Film

This section explains how to create your own animated short subject using *Film Director*. It guides you step-by-step from cutting out patterns to putting together a sequence of frames. During the session you will use most of *Film Director*'s toolboxes and gain experience with more than 20 tools.

The film you will create contains two parts. In the first part, a boy moves across a forest background, doing jumping jacks. All elements for this part will be taken from the *Film Director* demonstration film Demo.Film. The second part shows a star appearing apparently out of nowhere. You will produce the elements needed for this part of the film using one of the *Film Director* toolboxes.

Loading Pictures

To begin creating your animated short subject, first load the file Demo.Film (if you haven't already done so). Follow the steps:

1. Insert your *Art & Film Director* graphics disk into the drive.

2. Select the Load Film option from the File menu. (If the third menu selection from the left is Design, you must select the Editor option from the Design menu before you can load a film.)

An item selector appears listing the film files and folders on the disk.
Tip: You may be running *Film Director* with a second floppy drive connected to your system or from a hard drive. If so, click on Disk to see the directory listings of your other drives.

3. Select Demo.Film in the item selector, then click on Open. Demo.Film loads and its first frame appears.

4. Move the cursor to Edit and select the Designer option from the menu.

The word "Design" replaces the word "Edit" in the menu bar, showing that you are now in Design mode.

5. Select Erase Script from the Options menu.
6. A dialog box warns that the erasure cannot be undone. Click on Erase. The patterns, polygons, groups, actors, stages, and frames (but not the pictures) of Demo.Film are erased from memory in order for you to create your own film elements.

Cutting Out Patterns

Cut out the patterns you are going to use in your animated film. Follow the steps:

1. Select the Patterns option from the Design menu.

Picture A, containing images of heads, torsos, shoes, and hands, appears. The cursor is either an arrow or crosshairs, depending on the position of the cursor. The pattern counter in the first line of the toolbox reads #0.
You will cut out the ten patterns shown from pictures A and B in order to make your animated film:

2. Move the mouse to place the crosshairs immediately above and to the left of the third head in the top row. Click to set the point.

3. Move the mouse to expand a box around the head. Make sure the right side of the box is immediately to the right of the head, and the bottom of the box is immediately under the head. Then click to cut out the first pattern.
Tip: The part of the picture directly under the crosshair lines will be included in your pattern, so be careful not to grab part of another image. If you accidentally place the beginning angle of the crosshairs in the wrong position, select Undo to cancel the action and begin again. If you clicked to cut out your pattern with the box in the wrong position, click on Cut to reset your crosshairs, then cut out that pattern again, correctly. You'll be able to delete the incorrect pattern later.

4. Click on Cut in the toolbox to reset the crosshairs. When you move the cursor into Picture A, the crosshairs reappear.

5. Repeat steps 2 to 4 to cut out all the patterns you need from picture A. When you cut out the shoe patterns, be sure to cut out each shoe separately. Each time you cut out a pattern, the pattern counter in the first line of the toolbox increases by one.

Tip: Not all patterns are visible. Use the scroll bars along the right side and bottom of Picture A to find all the patterns you need. The windows in Patterns are used in the same way as the windows in Art Director.

6. Click on Picture A in the toolbox. Picture B appears.

7. Repeat steps 2 through 4 to cut out the tree trunk and treetop patterns.

Make a large blue rectangle to represent the sky in your film. Follow the steps:

1. Click on the sky-blue color in the palette at the bottom of the toolbox. The animation board turns sky blue.

2. Cut out a rectangle that is the width of the animation board but only half as high.

3. Move the cursor onto the toolbox and click on Picture to return picture B to the screen.

To see the patterns you cut out, click on < in <Step> in the toolbox. Look through all your patterns. If a pattern is incorrect you can delete it. When the pattern is on screen, click on Rearrange. In the dialog box that appears, click on Delete, then click on OK in the warning box. The pattern is deleted.

If you need to make a replacement pattern, return to the appropriate picture and cut out the pattern again. The new pattern is assigned the last number in the pattern series.

Tip: You've used several options in the Patterns toolbox. For a complete description of all the options, see the Film Director Reference later in this manual.

Making Polygons

Polygons are linear designs used primarily as props or backdrops in a film. To draw a polygon, follow these steps:
1. Select Polygons from the Design menu. The screen goes blank and the Polygons toolbox appears.

2. Click anywhere on the animation board to set the first point.

3. Move the arrow. A line follows it from the first point. Click again to set the second point.

4. Move the cursor and click again for each subsequent point.

5. Click twice on the last point without moving the mouse to finish the polygon. The toolbox reappears with a palette at the bottom.

6. To change the shape of the polygon, move the cursor to a side or angle of the polygon and hold down the mouse button. The arrow changes to a hand pinching the side or angle.

7. Move the mouse to drag the point to a new location. (When you pinch a side, you create a new angle.)

8. Release the mouse button to set the shape.

Click on Undo in the toolbox to erase the polygon. Then follow steps 2 through 8 to draw a large star for the second part of your film.

With Film Director, you can generate a series of images between elements in order to achieve animation. The greater the number of images, the smoother the animation looks. Do this with your star to make it seem to grow from nowhere. Follow the steps:

1. Click on Edit in the Polygons toolbox. A dialog box appears.
2. Click on Single. A second dialog box appears.

```
  File Design Options
  Insert  Delete
  Copy    Append

  1 POLYGON
  Cancel
```

3. Click on Insert. In the next dialog box, click on OK. A blank animation board appears. This is polygon #1. Your star has become polygon #2.

4. Click on > in <Step> to see polygon #2.

5. Click on Edit in the toolbox. Its dialog box appears.

6. Type 5 to indicate the number of intermediate stars that will be created. The number 5 appears in the dialog box.

7. Click on OK. A second dialog box appears.

8. Click on Tween, then click on OK in the next dialog box. The five in-between stars are generated. Your star appears on screen as polygon #7.

9. Look at the animation effect by pointing to < in <Step> and holding down the mouse button.

**Forming Groups**

Now use your patterns to create these groups:

- A tree made up of two patterns—the tree trunk and treetop.
- Two boys, each consisting of six patterns—a head, a torso, two hands, and two shoes.
To create the tree group, follow these steps:

1. Select the Groups option from the Design menu. The Groups toolbox appears on a blank animation board.

2. Click on Cel in the toolbox. A dialog box appears.

3. Click on Insert in the dialog box. The Layer, Pattern, and Polygon tools are added to the bottom of the Groups toolbox.

4. Click on < in <Pattern> until the tree trunk appears.

5. Move the arrow onto the tree trunk. Hold down the mouse button and drag the tree trunk around the animation board. When the tree trunk is where you want it, release the mouse button.

Repeat steps 2 to 5 to select and place the treetop on the tree trunk. You have now created a group.

To define a different group, you need to start with a blank animation board. Follow the steps:

1. Click on Edit in the Groups toolbox. A dialog box appears.

2. Click on Single to select one cycle without changing the cycle number. A second dialog box appears.

3. Click on Insert, then click on OK in the third dialog box. The screen displays a blank animation board.

4. Following the same steps you used to create a tree group, create the two boy groups shown below:
The two boy groups have some common elements. When creating the groups, you can save time by duplicating the common elements, then adding the patterns that are different. Follow these steps:

1. Create the first boy group.

2. Copy this group by clicking on Edit in the toolbox. A dialog box appears.

3. Click on Single, then click on Copy in the second dialog box. Finally, click on OK in the third dialog box.

4. Click on > in <Step> to display group #2. (Check the first line in the toolbox to make sure it shows #2.)

5. Click on a hand, then click on < or > in <Pattern> until the hand you want appears.

6. Move the cursor onto the hand. Holding down the mouse button, drag the hand to its new position. Move the cursor away and click to set the hand.

Repeat steps 5 and 6 to move or replace the patterns in group #2 until the boy is in the second position for jumping jacks.

Use the toolbox to erase mistakes or unwanted patterns:

- To delete one pattern only from your group, click on the pattern. A flashing box appears around it. Next, click on Cel in the toolbox. In the dialog boxes that appear, click on Delete, then on OK.

- To reverse all edits and return to your original group, click on Undo in the toolbox.

- To delete a group, click on Edit in the toolbox. In the dialog boxes that appear, choose the cycle number for the number of groups you want to delete. Click on Delete, then on OK.

**Animating Actors**

The next step in making your animated film is to define the boy doing jumping jacks as an actor. Actors have action steps called phases. The boy actor has two phases. Follow these steps:

1. Select Actors from the Design menu. The Actors toolbox and a blank animation board appear.

2. Click on Phase in the toolbox. A dialog box appears.

3. Click on Insert. Four new tools are added at the bottom of the Actors toolbox.

4. Click on < or > in <Group> until the first boy group appears. This creates the first phase.
5. Click on the center of <Ph 1>, then on Insert in the dialog box that appears. You've created a copy of the first phase.

6. Click on < or > in <Group> until the second boy group appears.

7. Click anywhere on the animation board away from the displayed group to animate the groups.

Now define the series of stars you created as another actor. Follow the steps:

1. Click on <Edit> in the toolbox. In the dialog boxes that appear, click on Single, then on Insert, then on OK.

2. Click on <Phase> in the toolbox and on Insert in the dialog box that appears.

3. Click on < or > in <Polygon> until the smallest star appears.

4. Click on the center of <Ph 1>, then on Insert in the dialog box.

5. Click on > in <Polygon> until the next larger star appears.

6. Repeat steps 4 and 5 with all the stars in order, until you create six phases with the six stars.

**Laying Out Stages**

Now's the time to establish a stage for the actors in your animated film. Do this by laying out a forest of trees. Follow the steps:


2. Click on Bkgnd Color in the toolbox. A selection box appears:
3. Click on a green color box, then on OK. The animation board fills with background color.

4. Next, add sky. Click on Cel in the toolbox. A dialog box appears.

5. Click on Insert in the dialog box.

6. Click on < or > in <Pattern> until the sky-blue rectangle appears.

7. Position your cursor on the rectangle, hold down the mouse button and drag the pattern to the top of the screen. Release the mouse button to set the sky in place.

Add trees to create a forested stage. Repeat steps 4 through 7 (click on < or > in <Group> in step 6 until the tree appears). Each time you repeat the steps, you'll add a tree.

When you're finished, you'll have created stage #1.

Creating Frames

You've now designed all the film elements and you're ready to insert them into frames. Follow the steps:

1. Select Editor from the Design menu. In the menu bar, the word "Design" changes to the word "Edit." Select Frames from the Edit menu. The Frames toolbox and a blank animation board appear.

2. Insert the stage. Click on < or > in <Stage> until stage #1 appears.

3. Click on Edit in the toolbox. A dialog box appears.

4. Type 20, then click on OK. A second dialog box appears.

5. Click on Copy, then on OK in the dialog box that appears.

6. Click on Cel in the toolbox, then on Insert in the dialog box that appears.

7. Click on < or > in <Actor> until actor #2, the boy, appears. A new tool, Record, is added at the bottom of the toolbox. Record places actors on existing frames, even those in which some animation has already been defined.

8. Move the cursor to the actor, hold down the mouse button, and drag the actor to where you want it to begin its animation.

9. Position the cursor on Record and press the mouse button to begin recording. Hold down the mouse button, and move the mouse to move your actor on the stage as it performs its animation. When the message "End of film, can't continue" appears on your screen, all the frames are filled and this part of your film is complete. Click to display the toolbox.
Now add your star to the film. Follow the steps:

1. Click on # in the toolbox. A dialog box appears.

![Select Frame Dialog Box](image)

2. Type 16, the number of the frame where the star will first appear, and click on OK.

3. Click on Cel in the toolbox, then click on Insert in the dialog box.

4. Click on < or > in <Actor> until the star appears. The Record tool is added to the bottom of the toolbox.

5. Click five times on Record in the toolbox to place the next five stars of your actor on the next five frames, or hold down the mouse button until you see the message "End of film, can't continue."

You've now finished your film. To see it, select the Show Film option from the Options menu, then click on OK in the dialog box. Then settle back and watch your film. To stop the film at any time, click the mouse button.

**Saving Your Film**

Unless they have been saved to disk, your film and all its elements are lost when your computer is turned off or a power interruption occurs. It's a good idea to save your films frequently to avoid losing your work if your computer is accidentally shut down.
Save your film to a formatted disk. Follow the steps:

1. Insert a formatted disk into your drive.

2. Make sure Edit is the third menu selection from the left. Select Save Film from the File menu. The item selector appears.

3. Type the filename Jumpjack in the Save Film box.

4. Click on Save. Your file is saved to disk.

Congratulations! You've successfully completed your first animated film. As you become familiar with Film Director, you will be able to use its advanced features to create increasingly complex animated films. These advanced features as well as Film Director's basic tools are fully described in the Film Director Reference section, next in this manual.
FILM DIRECTOR REFERENCE

When you first load Film Director, its main screen appears. This is where you create and animate images with Film Director tools.

**Message**

The message in the lower left corner suggests your next action and often gives information about the current screen. The message changes as you perform operations on screen.

When you first load Film Director, the message is Blank Object, indicating that the frame is empty.

**Cursor Coordinates (H,V)**

The cursor coordinates give the location of your cursor in pixels from the upper left corner of the Film Director animation board. They behave exactly the same way as the cursor coordinates in Art Director.

**Toolbox**

The toolbox contains many of the features you'll use to create your animated films. Occasionally you'll want to hide the toolbox. To do that, select Hide Toolbox from the Options menu, press Open Apple 0, or click on the close box. Select Show Toolbox from the Options menu or press Open Apple 0 again to return the toolbox to the screen.
To move a toolbox, place the cursor on the toolbox identifier (which is also the move bar). Hold down the mouse button and move the mouse left or right. The toolbox follows your mouse movements. Release the mouse button when the toolbox is where you want it.

When you first load *Film Director*, you see the Frames toolbox. This toolbox is described in the Frames section later in this manual.

Tip: The tools in the toolbox change, depending on the options you select from the menu bar. Each particular toolbox is described in the section discussing the menu option it belongs to.

**Animation Board**

The animation board is where you create your films. It’s equivalent to the canvas in *Art Director*, except that you see the entire animation board and do not use windows except when using the Patterns option in the Design menu.

**Film Director Menu Bar**

The menu bar across the top of your screen has the following selections, each with its own menu of options you’ll use when working with *Film Director*.

- **Apple**  The Apple menu contains an option that displays the program credits and version number. It also contains any desk accessories that exist on your boot disk.

- **File**  The File menu contains options for loading, saving, and deleting pictures, scripts, and film files. It also provides options for saving the program preferences you set while using *Film Director*, and exiting the program.

- **Edit**  Edit is the third selection in the menu bar. The Edit menu provides options for inserting film elements into frames, adding special effects, and editing film sequences.

- **Design**  When the Designer option is selected from the Edit menu, Design becomes the third menu bar selection. The Design menu contains options for designing film elements and modifying the palette.

- **Options**  The Options menu includes options for controlling the on-screen components, erasing frames, scripts, and pictures, and previewing a film.

Position the cursor on the menu bar, then hold down the mouse button and move the cursor across the menu bar. As the cursor touches each selection, the menu for that selection is displayed. Move the cursor down a menu to highlight its options. When an option is highlighted, release the mouse button to select it.
Apple Menu Options

The Apple menu contains the About option and any desk accessories available from your boot disk.

About

When you select About, a dialog box displays the Film Director credits. Click on OK to return to the main screen.

Desk Accessories

Any desk accessories contained in the Desk Accessories folder inside the System folder of the disk you booted from will be available in the Apple menu. For more information on desk accessories, consult your computer manual.

File Menu Options (Edit Mode)

The File menu contains options for loading, saving, and deleting pictures, scripts, and film files. It also provides options for saving the program preferences you set while using Film Director, and exiting the program.

The options in the menu change, depending on whether you're in Edit or Design mode. When you're in Edit mode, Edit is the third menu bar selection from the left. When you're in Design mode, Design is the third selection.
Load Film

When you select Load Film, an item selector appears. The directory lists film files you can load onto the animation board. Use the item selector in the same way you use the Load Picture item selector in Art Director. When you click on Open, your film is loaded onto the animation board.

Save Film

When you select Save Film, an item selector appears. Here you can type in new filenames for films just created, or save previously created films that you've edited. Use the item selector in the same way you use the Save Picture item selector in Art Director. When you click on Save or press Return, your film is saved to disk.

Load Music

When you select Load Music, its item selector appears. The directory lists music files you can load in order to add sound effects to your films. Use the item selector in the same way you use the Load Picture item selector in Art Director. When you click on Open, your music file is loaded.

For complete information on adding sound to your films, see the Sound section on page 93.

Save Screen

The Save Screen option saves the current Film Director screen of patterns, polygons, groups, actors, or a single frame. When you select the option, an item selector appears. Use it in the same way you use the Save Picture item selector in Art Director. The current screen will be saved as an art file.

Save Preferences

The settings you select with the Border Color, Display Tools, and Hide Messages options in the Options menu are saved to disk when you select Save Preferences. Use this option in the same way you use the Save Preferences option in Art Director. The settings are saved to a file named F.Pre.

Make sure the disk containing the Film Director program Film.Director is in your working drive before you select Save Preferences. Then save your preferences to the directory that contains the file Film.Director.
Delete File

The Delete File option lets you erase a file from disk. When you select this option, an item selector appears. Use it in the same way you use the Delete File item selector in Art Director. When you click on Delete, a warning box appears. Click on Delete again and the file will be deleted from the disk.

Tip: Be certain you want to delete the file before selecting Delete. Once a file is deleted, it cannot be recovered.

Quit

Select Quit to exit the Film Director program. Use this option in the same way you use Quit in Art Director.

File Menu Options (Design Mode)

The File menu contains four different options when in Design mode. The Save Preferences and Quit options work the same as in Edit mode.

Load Script

Select the Load Script option to load a script file. A script file contains information about all the patterns, polygons, groups, actors, stages, and frames used in a film, but it does not contain the pictures.

When you select Load Script, an item selector appears. Use it in the same way you use the Load Picture item selector in Art Director. When you click on Open, the file is loaded into Film Director.
Load Picture

Select the Load Picture option to load an art file. An art file contains a canvas of pictures from *Art Director* that you can cut out as patterns for a film.

When you select Load Picture, a selection box appears listing all available picture locations in *Film Director*. Click on the location you want to load the picture file to. If a picture is already in that location, the program warns you that loading another picture will overwrite the existing one. If you want to replace the old picture with the selected one, click on OK.

An item selector appears. To load your picture, use the item selector in the same way you use the Load Picture item selector in *Art Director*. When you click on Open, the art file will be loaded onto the selected pattern page.

Tip: The palettes used in your film will be the palettes of picture A.

Save Script

Select the Save Script option when you want to save a script file. A script file contains information about all the patterns, polygons, groups, actors, stages, and frames used in a film, but it does not contain the pictures. This is useful when you want many files containing different design elements cut from the same pictures. When you select Save Script, an item selector appears. Use it in the same way you use the Save Picture item selector in *Art Director*. When you click on Save, the file will be saved as a script file.

Save Picture

Select the Save Picture option to save a pattern picture as an art file. Doing this lets you load the picture back into *Art Director* if you want to modify it. A selection box appears listing all available picture locations in *Film Director*. Click on the location of the picture you want to save.

An item selector appears. To save your picture, use the item selector in the same way you use the Save Picture item selector in *Art Director*. When you click on Save, the selected pattern page will be saved as an art file.

Edit Menu Options

The Edit menu provides options for inserting film elements into frames, adding special effects, and editing film sequences.
Frames

The Frames option lets you create and edit single frames of an animated film. When you select Frames, its toolbox appears with the current frame. Use the Frames tools to add predefined patterns, polygons, groups, actors, stages, and sounds to individual frames.

Frame Counter  Shows the number of the frame currently on screen. Click on the counter and the frame selection box appears.

- Type in the number of the frame you want to see. When you click on OK, the frame appears.
- Click on either First or Last to see the first or last frame in the film.
- Click on Mark 1 or Mark 2 to see either the first or last marked frame in a sequence. (Frames are marked with the Mark tool in the Sequence toolbox.)
• When you have more than one frame, a box appears in the slide bar. Drag the box right or left to change the frame number in the selection box. Click on either arrow to increase or decrease the frame number by one. Click on the gray area on either side of the box to increase or decrease the number by ten. When you click on OK, the selected frame appears.

<Step> Displays the next frame in a series. Click on < or > to display the next frame backward or forward. Hold down the mouse button on < or > to scan the entire series backward or forward.

Edit Inserts, deletes, duplicates, and tweens frames. When you click on Edit, a dialog box appears asking for the number of cycles. (For Insert and Delete, the number of cycles is the number of frames you want to affect. For Copy and Append, it is the number of times one frame is duplicated. For Tween, it is the number of frames inserted between two selected frames.)

• Type in the number of cycles. Or click on Single to choose only one cycle without changing the current cycle number. If necessary, click on OK. A selection box appears.

• Select Insert to add the selected number of blank frames, then click on OK in the dialog box that appears. The frames are inserted before the current frame and all following frames are renumbered.

• Select Delete to erase the selected number of frames, then click on OK in the dialog box that appears. The frames are deleted, beginning with the current frame, and all following frames are renumbered.

• Select Copy to duplicate the current frame the selected number of times, then click on OK in the dialog box that appears. The duplicate frames are generated and added to the series before the current frame. The first duplicated frame appears on screen and takes the counter number of the original frame. The original frame is given a new number depending on how many duplicate frames were added before it in the series. All following frames are also renumbered.

Tip: If the frame you are copying is the frame marked as 1, the duplicate frames are added after (not before) the original frame. See Sequence for complete information on marking frames.

• Select Append to duplicate the current frame the selected number of times and add those new frames to the end of the series. Click on OK in the dialog box that appears to complete the operation.

• Select Tween to generate the selected number of frames between the current frame and the frame preceding it. Click on OK in the dialog box that appears. The frames are generated and all subsequent frames are renumbered.
Tween generates intermediate frames between the current frame and the preceding frame. For example, if you place element #1 (where the element is a pattern, polygon, or group) on frame #1, then place element #9 (which must be the same kind of element as element #1—for example, both elements must be groups) on frame #2, tweening seven frames will create seven frames with elements #2 through #8 in order, one element per frame. If your starting and ending elements are in different places on the animation board, the intermediate images will be placed along a line between the original two images, so that the image appears to move. When you step through your frames, the elements you tweened will appear to move or change. When you tween frames, each individual element in the frame is tweened.

Tip: Tweening cannot be performed on frame #1.

Undo Cancels all actions taken from the toolbox in the current editing session. Click on Undo to cancel.

Stage Places a predefined stage behind all foreground elements on your frame. Click on < or > to place the next stage backward or forward. Hold down the mouse button on < or > to scan the entire series of stages backward or forward.

When you click on the center of <Stage>, its selection box appears.

• Type in the number of the stage you want to see. When you click on OK, the stage appears.

• Click on either First or Last to see the first or last stage in the series.

• When you have more than one stage, a box appears in the slide bar. Drag the box right or left to change the stage number. Click on either arrow to increase or decrease the stage number by one. Click on the gray area on either side of the box to increase or decrease the number by ten. When you click on OK, the selected stage appears.

Palette Shows the palette currently selected for your frame. Click on Palette to see a selection box offering 16 palette selections lettered A through P. Click on a letter to select that palette, then click on OK. The new palette letter appears in the toolbox, and your frame is shown in the colors of that palette.

The colors in the current palette appear below the lettered boxes in the palette selection box. These colors can be modified with the Palettes option in the Design menu. For details, see Palettes beginning on page 115.

Sound After you have loaded a music file (see Load Music earlier in this manual) you can use this tool to add sound effects to the current frame. Click on Sound to see its selection box offering nine sound selections numbered 1 through 9. Click on a number to select that sound.
- Click on Play to preview the sound.
- Select Off to shorten a sound. When a sound is played in a frame, it will play until it is finished even though it may take many frames. Use Off in a frame where you want to stop all sounds currently being played.
- Select None if you want no sound selected for your frame. (This is the default selection.)

Make your selection and click on OK. Your selection appears in the toolbox.

**Cel** Lets you add or delete patterns, polygons, groups, or actors in your film. Each element is added as a cel layered onto the current frame.

When you click on Cel, its selection box appears. When you select Insert from the selection box, tools are added to the toolbox for these five items: layers, patterns, polygons, groups, and actors.

Patterns, polygons, groups, and actors are created with options from the Design menu. (See **Design Menu Options** later in this manual for full details.) To generally describe them, they are the images in your film to be animated. They are placed onto a frame in layers, with one pattern, polygon, group, or actor in each layer. To change an image's layering, click on it. Then click on the up or down arrow in the Layer tool to place the image in front of or behind an image it overlaps.

**Tip:** You cannot place a cel behind a stage.

Click on the center of <Pattern>, <Polygon>, <Group>, or <Actor> to see its selection box.

- Type in the number of the element you want to see. When you click on OK, that element appears.
- Click on either First or Last to see the first or last element in the series.
- When you have more than one element available, a box appears in the slide bar. Drag the box right or left to change the element number showing in the selection box. Click on either arrow to increase or decrease the element number by one. Click on the gray area on either side of the box to increase or decrease the number by ten. When you click on OK, the selected element appears.

You can also choose an element by clicking on < or > in <Pattern>, <Polygon>, <Group>, or <Actor>. Your inserted element will change to the next or previous element, depending on which arrow you click on.

Move the cursor to the element, hold down the mouse button, and drag the element to where you want it in the frame. Release the mouse button to set it in place.
**Film Director**

**Tip:** If you find that you cannot line up your elements vertically, return to *Art Director* and adjust the position of the elements on the canvas. For more information, see *Creating Art for Film Director* earlier in this manual.

When you select <Actor>, another tool, Record, is added to the toolbox and the first phase of your actor appears. Position the phase where you want it, then click on Record to set the phase in place. Your frame advances by one and the next phase of the actor appears. Continue positioning and recording your actor phases on the frames until your actor’s motion is complete.

If you want to record each actor phase more quickly but less precisely, you can position the cursor on Record, hold down the mouse button, then move the mouse to move your actor as it is recorded on your existing frames. Release the mouse button when you are finished.

**Tip:** At any time during a Record operation, you can change the layering of your actor by clicking on the Layer arrows. Doing this determines whether the actor is behind or in front of the elements it passes.

To delete an element from a frame, first click on it on the animation board. Then select Cel from the toolbox and Delete from the selection box that appears. Finally, click on OK in the warning box. The element is removed from your frame.

**Sequence**

The Sequence option lets you edit, view, or add special effects to a series of frames. When you select Sequence from the Edit menu, its toolbox appears.
Frame Counter  Your sequence contains a number of frames. The frame
counter shows the number of the frame currently on screen. Click on the counter
and the frame selection box appears.

- Type in the number of the frame you want to see. When you click on OK, the
  frame appears.

- Click on either First or Last to see the first or last frame in the film.

- Click on Mark 1 or Mark 2 to see either the first or last marked frame in a
  sequence. (Frames are marked with the Mark tool in the toolbox.)

- When you have more than one frame, a box appears in the slide bar. Drag the
  box right or left to change the frame number in the selection box. Click on
  either arrow to increase or decrease the frame number by one. Click on the
  gray area on either side of the box to increase or decrease the number by ten.
  When you click on OK, the selected frame appears.

<Step> Displays the next frame of the film. Click on < or > to display the next
frame backward or forward. Hold down the mouse button on < or > to scan the
entire film backward or forward.

Edit  Deletes, copies, or appends a sequence in your film. The limits of the
sequence to be affected are determined by the frames you've marked as 1 and 2
in the film.

- Select Delete to delete the frames marked 1 and 2 and all frames between
  them from your film. Click on OK in the warning box to complete the
  operation.

- Select Copy to duplicate the frames marked 1 and 2 and all frames between
  them. Click on OK in the dialog box that appears to complete the operation.
  The frames will be copied in sequence and inserted before your current frame.

- Select Append to add the frames marked 1 and 2 and all frames between
  them to the end of your film. Click on OK in the dialog box to complete the
  operation.

Mark  Use this tool to mark the frame currently on screen as either the begin-
ning frame (1) or the ending frame (2) of your sequence. When the frame you
want to mark is on screen, click on either 1 or 2 to mark it. The two frames
marked as 1 and 2 and all frames between them become the marked sequence.

Stage  Selects a stage to be added to all the frames in the sequence. The begin-
ning and ending frames of the sequence are defined by mark 1 and mark 2.
When you click on Stage, its selection box appears.

- Type in the number of the stage you want to see. When you click on OK (both
  in the selection box and in the dialog box that appears), that stage is placed in
  all frames of your sequence.
- Click on either First or Last to see the first or last stage in a series. When you click on OK in the dialog box, the selected stage appears and is placed in all frames of your sequence.

- When you have more than one stage, a box appears in the slide bar. Drag the box right or left to change the stage number in the selection box. Click on either arrow to increase or decrease the stage number by one. Click on the gray area on either side of the box to increase or decrease the number by ten. When you click on OK (both in the selection box and in the dialog box that appears), the selected stage appears and is placed in all frames of your sequence.

Palette  Click on Palette to see a selection box offering 16 palette selections lettered A through P. Click on a letter to select that palette, then click on OK. The chosen palette is selected for all the frames in the sequence.

The colors in the current palette appear below the lettered boxes in the palette selection box. These colors can be modified with the Palettes option in the Design menu. For details, see Palettes beginning on page 115.

View  Previews the sequence of frames defined by mark 1 and mark 2. Click on View to see its selection box. The number in the selection box is your current film speed. Speeds range from 1 to 9. Click on Slower or Faster to change the speed, or type a number from 1 to 9. Lower numbers slow down the film; higher numbers speed it up. Then click on OK to preview your sequence.

Tip: If the frame marked 1 has a higher frame number than the frame marked 2, your sequence will run in reverse when you view it.

Cel  Lets you manipulate the elements you added to your frames with the Cel tool in the Frames toolbox. Select Cel to see its selection box.

- Interpolate  Lets you add intermediate images on the top layer of a sequence. First, use the Frames toolbox to place beginning and ending versions of a pattern, polygon, or group onto two different frames. (Both elements must be the same kind of element—for example, two groups.) Return to the toolbox and use the Mark tool to mark the frames as 1 and 2. Finally, select Cel and click on Interpolate in the selection box, then on OK in the dialog box that appears. Interpolate will add intermediate elements on the frames between the marked frames.

For example, if you place group #1 on frame #1, then place group #9 on frame #9, Interpolate will place groups #2 through #8 on frames #2 through #8 for you. If your starting and ending images are in different places on the animation board, the intermediate images will be placed along a line between the images to make the image appear to move from the first place to the last. When you view your sequence, the element you interpolated will appear to move or change.
- **Overlay** Copies all patterns, polygons, and groups in a sequence, then adds the copies to the film, beginning with the current frame. After marking your sequence, select Overlay, then click on OK in the dialog box that appears. In your frame, move the mouse to position the elements and click to set the overlay in place. Overlay is useful for superimposing sequences. For example, you can add a sequence of a boy riding a bike to a sequence of a boy throwing a ball. Or you can copy a sequence of a soldier marching to make a line of marching soldiers.

- **Peel** Erases the topmost elements from a sequence. After marking your sequence, select Peel, then click on OK in the dialog box that appears. Elements copied to your film by mistake with Interpolate and Overlay can often be easily erased with Peel, since the appropriate sequence is already marked.

- **Trace On** Creates a trail of after-images of actors as they "move" through a marked sequence. Select Trace On, then click on OK in the dialog box that appears. The Trace function is seen when the film is viewed in Sequences or when it is shown with the Show Film option in the Options menu. Trace is a helpful tool for analyzing animation. For example, if you want to have a bird flying across the screen, mark it as a sequence and activate Trace On. When you view the sequence, all of the images of the bird are left on the screen, so you can find any frames where the bird is not positioned correctly for the path you want it to follow.

  **Tip:** If your stage changes while you are viewing or showing a film, all after-images are erased.

- **Trace Off** Turns off the Trace On operation in a marked sequence. Select Trace Off, then click on OK in the dialog box that appears. If the marked sequence is not the same as when you activated Trace On, some frames may have Trace On still activated after you select Trace Off.

**Designer**

Selecting Designer puts you in Design mode, with Design as the third menu bar selection from the left. For complete information, see the next section, **Design Menu Options**.
Design Menu Options

The Design menu contains options for designing film elements.

Patterns

The Patterns option lets you create patterns to use in your films. When you select this option, its toolbox appears alongside the current picture window. Use the Patterns tools to create, edit, and cut out patterns from art pictures you have loaded into memory with the Load Picture option in the File menu.
**Pattern Counter**  Shows the number of the pattern currently on screen, or, if the window is visible, the total number of patterns cut.

- Type in the number of the pattern you want to see. When you click on OK, that pattern appears.
- Click on either First or Last to see the first or last pattern in the series.
- When you have more than one pattern in your series, a box appears in the slide bar. Drag the box right or left to change the pattern number in the selection box. Click on either arrow to increase or decrease the pattern number by one. Click on the gray area on either side of the box to increase or decrease the number by ten. When you click on OK, the selected pattern appears.

**<Step>** Displays the next pattern in a series. Click on < or > to display the next pattern backward or forward. Hold down the mouse button on < or > to scan the entire series backward or forward.

**Rearrange** Inserts, deletes, and rearranges the order of patterns. Select Rearrange to see its selection box.

- Select Insert to insert a blank pattern before the current position. Then click on OK in the dialog box that appears. The blank pattern is inserted and all following patterns are renumbered. This function is used to change the order of your patterns when used with the Get option.
- Select Delete to delete the current pattern. Then click on OK in the dialog box that appears. The pattern is deleted and all following patterns are renumbered. Use this feature to delete incorrectly cut or unwanted patterns.
- Select Send to move the current pattern to the end of the pattern series. Then click on OK in the dialog box that appears. The pattern is moved and all following patterns are renumbered. This function is helpful for reordering your patterns.
- Select Get to bring the last pattern in the series into the current position. Then click on OK in the dialog box that appears. The last pattern appears in the current position and the current pattern is deleted. This is especially helpful when you have cut out a pattern incorrectly but have already used it in groups or other more complex elements. Cut out the pattern again, correctly, then select the pattern you wish to replace with the new one. Select Get to replace the old pattern with the new pattern.

Patterns must be cut in a certain order to make later functions effective and easy to use. Use the Rearrange functions to change the order of your patterns without having to recut them if you decide on a more useful order. To change a pattern’s position in the series, first send it to the end of the series. Then insert a blank pattern where you want the pattern to be moved to. Finally get the pattern from the end of the series with the Get option, placing it over the blank pattern.
Undo  Undo reverses the last line drawn with the Draw feature. Also, if you set
the first point of a cut in the wrong place, click on Undo to start again. A pattern
that has been cut out or rearranged cannot be undone.

Draw  Lets you draw a new picture or edit an existing picture. When you click
on Draw, the toolbox gives you a color swatch and zoom tool.

Move the cursor onto a color in the palette and click to select it. That color
appears in the color swatch. Then move the cursor onto the animation board,
where it becomes a pencil. Hold down the mouse button while moving the
mouse to draw in the color you selected. You can draw over existing pictures or
create new pictures.

Click on Zoom in the toolbox to magnify an area for detailed drawing. Move the
cursor onto the animation board, and it becomes a box. Position the box over the
area you want to magnify, then click to display the magnified area. Move the
cursor (a small box) over the area and click to add a single pixel of color at the
cursor position.

To exit Zoom, click on Draw in the toolbox. To exit Draw, click on Exit.

Cut  Cuts out a pattern. Select Cut, then move the cursor onto the animation
board where it becomes crosshairs. Position the bars of the cursor over the top
and to the left of the pattern you want to cut, and click. Move the mouse to the
right. A box follows the cursor. When the box encloses the pattern, click to cut
out the pattern. The pattern is added at the end of your pattern series (and the
number in the counter is increased by one). You now have a box for a cursor
that you can use to cut out patterns of the same size with a single mouse click.
Select Cut to reset your crosshairs.

Tip: If you find that you cannot cut out all of your image without cutting out
part of an adjacent image, return to Art Director and adjust the spacing between
the elements on the canvas. For more information, see Creating Art for Film
Director earlier in this manual.

Picture  Lets you select a picture to display. The letter of your current picture is
listed in the toolbox. If you have more than one picture loaded, click on Picture
in the toolbox to view the other pictures. Click on the right side of Picture to
step forward through the pictures, and on the left side to step backward.

Palette  Shows the 16 colors available for use in your current picture. Click on a
color in the palette to fill the screen with that color. Then use Cut to cut out a
rectangle of color to use as a pattern. Click on Picture in the toolbox to return to
your current picture.

When using the Draw tool, click on a color in the palette to select it for drawing.

Tip: To change the colors in your palette, use the Palettes option in the Design
menu. For complete instructions, see the Palettes beginning on page 115.
Polygons

The Polygons option lets you draw, color, and edit line drawings to use in your films. When you select this option, the Polygons toolbox appears.

Move the cursor onto the animation board and click to set the first point of your polygon. Then move the mouse to extend a line. Click to set the second point of the polygon. Continue moving the mouse and clicking to set all subsequent points of your design. When the polygon is finished, click twice without moving the mouse. The palette and Clip tools are added to the toolbox.

**Polygon Counter** Shows the number of the polygon currently on screen. Click on the counter and the polygon selection box appears.

- Type in the number of the polygon you want to see. When you click on OK, that polygon appears.

- Click on either First or Last to see the first or last polygon in the series.

- When you have more than one polygon in your series, a box appears in the slide bar. Drag the box right or left to change the polygon number in the selection box. Click on either arrow to increase or decrease the polygon number by one. Click on the gray area on either side of the box to increase or decrease the number by ten. When you click on OK, the selected polygon appears.

**<Step>** Displays the next polygon in a series. Click on < or > to display the next polygon backward or forward. Hold down the mouse button on < or > to scan the entire series backward or forward.

**Edit** Inserts, deletes, and duplicates polygons, and generates intermediate polygons (tweening) between two existing polygons.
When you click on Edit, a dialog box appears asking for the number of cycles. (For Insert and Delete, the number of cycles is the number of polygons you want to affect. For Copy and Append, it is the number of times one polygon is duplicated. For Tween, it is the number of intermediate polygons inserted between two selected polygons.) Type in the number of cycles, then click on OK. Or click on Single for only one cycle. A selection box appears.

- Select Insert to add the selected number of blank polygons, then click on OK in the dialog box that appears. The polygons are inserted before the current polygon and all following polygons are renumbered.

- Select Delete to delete the selected number of polygons, then click on OK in the dialog box that appears. The polygons are deleted, beginning with the current polygon, and all following polygons are renumbered.

- Select Copy to duplicate the current polygon the selected number of times, then click on OK in the dialog box that appears. The duplicate polygons are generated and added to the series before the current polygon. The first duplicated polygon appears on screen and takes the counter number of the original polygon. The original polygon is given a new number depending on how many duplicate polygons were added before it in the series. All following polygons are also renumbered.

- Select Append to duplicate the current polygon the selected number of times and add those new polygons to the end of the series. Click on OK in the dialog box that appears to complete the operation.

- Select Tween to generate the selected number of intermediate polygons between the current polygon and the polygon preceding it. Click on OK in the dialog box that appears. The polygons are generated and all following polygons are renumbered.

When the selected polygons are different sizes and shapes, Tween generates a series of "changing" polygons. When the series is viewed as a sequence, the polygon appears to grow or change.

When the selected polygons are identical but in different positions, Tween generates a series of repositioned polygons. When the series is viewed as a sequence, the polygon appears to move.

Tip: You cannot perform a Tween from polygon #1. If you want to make a polygon grow from a point with Tween, insert a blank polygon before it.

Undo Cancels all actions taken from the toolbox for the current editing session. Click on Undo to cancel.
Stage> Lets you preview an existing stage with your current polygon, in order to align the polygon correctly for use on that stage later when you set up your frames. Click on < or > to see the next available stage backward or forward. Hold down the mouse button on < or > to scan the entire series of stages backward or forward. Click on the tool to see its selection box.

- Type in the number of the stage you want to see. When you click on OK, that stage appears on your animation board, behind the polygon.
- Click on either First or Last to see the first or last stage in the series. The selected stage appears behind the current polygon.
- A box appears in the slide bar. Drag the box right or left to change the stage number in the selection box. Click on either arrow to increase or decrease the stage number by one. Click on the gray area on either side of the box to increase or decrease the number by ten. When you click on OK, the selected stage appears behind the current polygon.

With a stage displayed, you can preview how your polygon looks on it. Move the cursor onto the animation board, away from your polygon. Hold down the mouse button. The cursor changes to a flat hand. Now move the mouse to move your polygon onto the stage. When the polygon is positioned correctly, release the mouse button.

If you position the cursor on a side or angle of your polygon and hold down the mouse button, the cursor changes to a hand pinching the polygon. Move the mouse to drag the point to a new position, then release the mouse button.

Tip: When you pinch a side, you create a new angle.

Palette Shows the 16 colors available for coloring your polygons. Click on a color in the palette to select it. Then move the arrow point onto a line in your polygon and click to color the line from angle to angle.

Tip: To change the colors in your palette, use the Palettes option in the Design menu. For complete instructions, see Palettes beginning on page 115.

Clip Deletes an angle of a polygon. Select Clip, then move the cursor (a pair of clippers) onto the polygon angle you want to clip. Click to delete the angle. The polygon reforms with one less angle.

Groups

The Groups option lets you create groups to use in your films. Groups are collections of patterns and polygons. When you select this option, its toolbox appears.
**Group Counter** Shows the number of the group currently on screen. Click on the counter and the group selection box appears.

- Type in the number of the group you want to see. When you click on OK, that group appears.

- Click on either First or Last to see the first or last group in the series.

- When you have more than one group, a box appears in the slide bar. Drag the box right or left to change the group number in the selection box. Click on either arrow to increase or decrease the group number by one. Click on the gray area on either side of the box to increase or decrease the number by ten. When you click on OK, the selected group appears.

**<Step>** Displays the next group in a series. Click on < or > to display the next group backward or forward. Hold down the mouse button on < or > to scan the entire series backward or forward.

**Edit** Inserts, deletes, and duplicates groups, and generates intermediate groups (tweening) between two existing groups.

When you click on Edit, a dialog box appears asking for the number of cycles. (For Insert and Delete, the number of cycles is the number of groups you want to affect. For Copy and Append, it is the number of times one group is duplicated. For Tween, it is the number of intermediate groups inserted between two selected groups.) Type in the number of cycles, then click on OK. Or click on Single for only one cycle. A selection box appears.
• Select Insert to add the selected number of blank groups, then click on OK in the dialog box that appears. The groups are inserted before the current group and all following groups are renumbered.

• Select Delete to delete the selected number of groups, then click on OK in the dialog box that appears. The groups are deleted, beginning with the current group, and all following groups are renumbered.

• Select Copy to duplicate the current group the selected number of times. Then click on OK in the dialog box that appears. The duplicate groups are generated and added to the series before the current group. The first duplicated group appears on screen and takes the counter number of the original group. The original group is given a new number depending on how many duplicate groups were added before it in the series. All following groups are also renumbered.

• Select Append to duplicate the current group the selected number of times and add those new groups to the end of the series. Click on OK in the dialog box that appears to complete the operation.

• Select Tween to generate the selected number of intermediate groups between the current group and the group preceding it. Click on OK in the dialog box. The groups are generated and all following groups are renumbered.

Tween will generate intermediate groups between the current group and the preceding group. For example, if you place pattern #1 in group #1, then place pattern #9 on group #2, tweening seven groups will create seven groups with patterns #2 through #8 in order, one pattern per group. If your starting and ending patterns are in different places on the animation board, the intermediate patterns will be placed along a line between the patterns to make the group appear to move from the first place to the last. The group you tweened appears to move or change when you step through your groups. When you tween groups, each individual pattern in the group is tweened layer for layer.

Tip: You cannot perform a Tween from group #1.

Undo Cancels all actions taken from the toolbox for the current editing session. Click on Undo to cancel.

<Stage> Lets you preview an existing stage with your current group, in order to align the group correctly for use on that stage later when you set up your frames. Click on < or > to see the next available stage backward or forward. Hold down the mouse button on < or > to scan the entire series of stages backward or forward. Click on the tool to see its selection box.

• Type in the number of the stage you want to see. When you click on OK, that stage appears on your animation board, behind the group.
• Click on either First or Last to see the first or last stage in the series. The selected stage appears behind the current group.

• A box appears in the slide bar. Drag the box right or left to change the stage number in the selection box. Click on either arrow to increase or decrease the stage number by one. Click on the gray area on either side of the box to increase or decrease the number by ten. When you click on OK, the selected stage appears behind the current group.

With a stage displayed, you can preview how your group looks on it. Move the cursor onto the animation board, away from your group. Hold down the mouse button. The cursor changes to a flat hand. Move the mouse to move your group on the stage. When the group is positioned correctly, release the mouse button.

If you position the cursor on a single element in the group and hold down the mouse button, the cursor changes to a hand pinching the element. Move the mouse to drag the element to a new position, then release the mouse button. A flashing box appears around the element indicating that it is currently selected.

Cel Lets you add or delete patterns and polygons from your group. Each element is added as a cel, or layer, to the current group.

When you click on Cel, its selection box appears. When you select Insert from the selection box, tools are added to the toolbox for these three items: layers, patterns, and polygons.

Patterns and polygons can be placed onto your group in layers, with one element per layer. To change an image's layering, click on it. Then click on the up or down arrow in the Layer tool to place the image in front of or behind an image it overlaps.

Click on the center of <Pattern> or <Polygon> to see its selection box.

• Type in the number of the element you want to see. When you click on OK, that element appears.

• Click on either First or Last to see the first or last element in the series. The selected element appears.

• When you have more than one element available, a box appears in the slide bar. Drag the box right or left to change the element number showing in the selection box. Click on either arrow to increase or decrease the element number by one. Click on the gray area on either side of the box to increase or decrease the element number by ten. When you click on OK, the selected element appears.

You can also choose an element by clicking on < or > in <Pattern> or <Polygon>. Your inserted element will change to the next or previous element, depending on which arrow you click on.
Move the cursor to the element, hold down the mouse button, and drag the element to where you want it in the group. Release the mouse button.

**Tip:** If you find that you cannot line up your elements vertically, return to *Art Director* and adjust the position of the elements on the canvas. For more information, see *Creating Art for Film Director* earlier in this manual.

To delete an element from a frame, first click on it on the animation board. Then select *Cel* from the toolbox and *Delete* from the selection box that appears. Click on *OK* in the warning box. The element is deleted from your frame.

**Actors**

The Actors option lets you arrange patterns, polygons, and groups into animated images called actors. When you select Actors from the Design menu, its toolbox appears.

![Image of File Design Options]

**Actor Counter** Shows the number of the actor currently on screen. Click on the counter and the actor selection box appears.

- Type in the number of the actor you want to see. When you click on *OK*, that actor appears.

- Click on either *First* or *Last* to see the first or last actor in the series.

- When you have more than one actor, a box appears in the slide bar. Drag the box right or left to change the actor number in the selection box. Click on either arrow to increase or decrease the actor number by one. Click on the gray area on either side of the box to increase or decrease the number by ten. When you click on *OK*, the selected actor appears.
<Step> Displays the next actor in a series. Click on < or > to display the next actor backward or forward. Hold down the mouse button on < or > to scan the entire series backward or forward.

Edit Inserts, deletes, and duplicates actors, and generates intermediate actor phases (tweening) between two existing phases.

When you click on Edit, a dialog box appears asking for the number of cycles. (For Insert and Delete, the number of cycles is the number of actors you want to affect. For Copy and Append, it is the number of times one actor is duplicated. For Tween, it is the number of intermediate actor phases inserted between two selected actor phases.) Type in the number of cycles, then click on OK. Or click on Single for only one cycle. A selection box appears.

- Select Insert to add the selected number of blank actors, then click on OK in the dialog box that appears. The actors are inserted before the current actor and all following actors are renumbered.

- Select Delete to delete the selected number of actors, then click on OK in the dialog box that appears. The actors are deleted, beginning with the current actor, and all following actors are renumbered.

- Select Copy to duplicate the current actor the selected number of times. Then click on OK in the dialog box that appears. The duplicate actors are added after the current actor and all following actors are renumbered.

- Select Append to duplicate the current actor the selected number of times and add those new actors to the end of the series. Click on OK in the dialog box that appears to complete the operation.

- Select Tween to generate the selected number of intermediate actor phases between the current actor phase and the phase preceding it. Click on OK in the dialog box that appears. The phases are generated and all following phases are renumbered.

Tip: You can only tween after you select a phase. Click on Phase to select it.

Tween generates intermediate phases between the current phase and the preceding phase. For example, if you place element #1 (an element can be a pattern, polygon, or group) in phase #1, then place element #9 in phase #2, tweening seven elements will insert seven phases with elements #2 through #8 in order, one element per phase. If your starting and ending phases are in different places on the animation board, the intermediate images are placed along a line between the phases to make the actor appear to move from the first place to the last. When you step through your phases, the element you tweened appears to move or change.

Tip: You cannot perform a Tween from phase #1.
Undo  Cancels all actions taken from the toolbox. Click on Undo to cancel.

<Stage>  Lets you preview an existing stage with your current actor, in order to position the actor correctly for use on that stage later when you set up your frames. Click on the tool to see its selection box.

- Type in the number of the stage you want to see. When you click on OK, that stage appears on your animation board, behind the actor.
- Click on either First or Last to see the first or last stage in the series. The selected stage appears behind the current actor.
- A box appears in the slide bar. Drag the box right or left to change the stage number in the selection box. Click on either arrow to increase or decrease the stage number by one. Click on the gray area on either side of the box to increase or decrease the number by ten. When you click on OK, the selected stage appears behind the current actor.

With a stage displayed, you can preview how your actor looks on it. Move the cursor onto the animation board, away from your actor. Hold down the mouse button. The cursor changes to a flat hand. Now move the mouse to move your actor on the stage. When the actor is positioned correctly, release the mouse button. The actor cycles through all its phases as you do this.

<Phase>  Displays, inserts, or deletes an actor's phases. Phases are cells that are individual action steps which, when viewed in sequence, make up an actor.

To add a phase to an actor that does not yet have phases, select Phase. Select Insert in the dialog box that appears. A phase is generated with a blank pattern—a flashing box—on it. Also, four tools are added to the toolbox for these items: order, pattern, polygon, and group.

Now choose the element for your phase by clicking on < or > in <Pattern>, <Polygon>, or <Group>. Your element changes to the next or previous element, depending on which arrow you click on. Or click on the center of the tool to see its selection box.

- Type in the number of the element you want to see. When you click on OK, that element appears.
- Click on either First or Last to see the first or last element in the series.
- When more than one element is available, a box appears in the slide bar. Drag the box right or left to change the element number shown in the selection box. Click on either arrow to increase or decrease the element number by one. Click on the gray area on either side of the box to increase or decrease the number by ten. When you click on OK, the selected element appears.

Move the cursor to the element, hold down the mouse button, and drag the element to where you want it in the phase. Release the mouse button to set it in...
place. Move the cursor away from your actor and click the mouse button to set your actor in motion. When you view the actor, that element appears in the selected phase.

Tip: If you find that you cannot line up your elements vertically, return to Art Director and adjust the position of the elements on the canvas. For more information, see Creating Art for Film Director earlier in this manual.

To add a phase to an actor that already has phases, select <Phase> while the actor is in motion. Then select Insert in the dialog box that appears. This adds a phase at the end of the series of phases. Then choose your element. If a phase of your actor is selected (your actor is not in motion), inserting a phase appends a copy of your selected phase to the end of the series and displays your copy.

To select a phase, click on < or > in <Phase> to stop the actor at the first or last phase. The number of the phase appears (for example, <Ph 7>). Move the cursor to < or > in <Phase> and hold down the mouse button to scroll backward or forward through the actor's phases.

The <Order> tool changes the sequence of two phases. Click on < to swap the current phase with the one that precedes it. Click on > to swap the current phase with the one that follows it.

To delete a phase, first display it by selecting < or > in the phase tool. Then click on the center of the tool. Select Delete from the dialog box, and click on OK in the second dialog box that appears. The phase is deleted from your actor.

Stages

The Stages option lets you establish a stage or background for your animated film. After you create a stage, place it into a frame by using the Frames or Sequences options in the Edit menu. Select Stages from the Design menu to see its toolbox.
Stage Counter  Shows the number of the stage currently on screen. Click on the counter and the stage selection box appears.

- Type in the number of the stage you want to see. When you click on OK, that stage appears.
- Click on either First or Last to see the first or last stage in the series.
- When you have more than one stage, a box appears in the slide bar. Drag the box right or left to change the stage number in the selection box. Click on either arrow to increase or decrease the stage number by one. Click on the gray area on either side of the box to increase or decrease the number by ten.

When you click on OK, the selected stage appears.

<Step>  Displays the next stage in a series. Click on < or > to display the next stage backward or forward. Hold down the mouse button on < or > to scan the entire series backward or forward.

Edit  Inserts, deletes, and duplicates stages, and generates intermediate stages between two existing stages.

When you click on Edit, a dialog box appears asking for the number of cycles. (For Insert and Delete, the number of cycles is the number of stages you want to affect. For Copy and Append, it is the number of times one stage is duplicated. For Tween, it is the number of intermediate stages inserted between two selected stages.) Type in the number of cycles. Or click on Single for only one cycle. A selection box appears.

- Select Insert to add the selected number of blank stages, then click on OK in the dialog box that appears. The stages are inserted before the current stage and all following stages are renumbered.
- Select Delete to delete the selected number of stages, then click on OK in the dialog box that appears. The stages are deleted, beginning with the current stage, and all following stages are renumbered.
- Select Copy to duplicate the current stage the selected number of times. Then click on OK in the dialog box that appears. The duplicate stages are generated and added to the series before the current stage. The first duplicated stage appears on screen and takes the counter number of the original stage. The original stage is given a new number depending on how many duplicate stages were added before it in the series. All following stages are also renumbered.
- Select Append to duplicate the current stage the selected number of times and add those new stages to the end of the series. Click on OK in the dialog box that appears to complete the operation.
* Select Tween to generate the selected number of intermediate stages between the current stage and the stage preceding it. Click on OK in the dialog box that appears. The stages are generated and all following stages are renumbered.

Tween will generate intermediate stages between the current stage and the preceding stage. For example, if you place element #1 on stage #1 (an element can be a pattern, polygon, or group), then place element #9 on stage #2, tweening seven stages will create seven stages with elements #2 through #8 in order, one element per stage. If your starting and ending elements are in different places on the animation board, the intermediate images will be placed along a line between the images to make the element appear to move from the first place to the last. The element you tweened appears to move or change when you step through your stages.

Tip: You cannot perform a Tween from stage #1.

Undo  Clicking on Undo cancels all actions taken from the toolbox for the current editing session.

Text  Lets you add text to your stage. When you click on Text, an underscore cursor appears in the lower left corner of the animation board. If you already typed text on your stage, the cursor will appear where you left off in the previous session. Use your Arrow keys to move the cursor to where you want text to begin. Then type your text. If you make a mistake, press Delete to erase.

After finishing a line of text, move the cursor again with your Arrow keys to add other lines. When you've typed all text, press Esc or click the mouse button to complete the operation.

Bkgnd Color  Lets you change the background color of your stage. When you click on the tool, its selection box appears, offering 16 color choices. Click on the color you want, then click on OK. The background color in your stage changes to the color you just selected.

Text Color  Lets you choose the color of text added to your stage with the Text tool. When you click on Text Color, its selection box appears, offering the 16 color choices from your palette. Click on the color you want, then click on OK. The text on your stage (and any text you add later) appears in the newly chosen color.

Cel  Lets you add or delete patterns, polygons, and groups in your stage. Each element is added as a cel, or layer, to the current stage.

When you click on Cel, its selection box appears. When you select Insert from the selection box, tools are added to the toolbox for these four items: layers, patterns, polygons, and groups.
Patterns, polygons, and groups can be placed onto your stage in layers, with one element per layer. To change an image’s layering, click on it. Then click on the up or down arrow in the Layer tool to place the image in front of or behind an image it overlaps.

Click on <Pattern>, <Polygon>, or <Group> to see its selection box.

- Type in the number of the element you want to see. When you click on OK, that element appears.

- Click on either First or Last to see the first or last element in the series.

- When more than one element is available, a box appears in the slide bar. Drag the box right or left to change the element number shown in the selection box. Click on either arrow to increase or decrease the element number by one. Click on the gray area on either side of the box to increase or decrease the number by ten. When you click on OK, the selected element appears.

You can also choose an element by clicking on < or > in <Pattern>, <Polygon>, or <Group>. Your inserted element changes to the next or previous element, depending on which arrow you click on.

Move the cursor to the element, hold down the mouse button, and drag the element to where you want it on the stage. Release the mouse button.

Tip: If you find that you cannot line up your elements vertically, return to Art Director and adjust the position of the elements on the canvas. For more information, see Creating Art for Film Director earlier in this manual.

To delete an element from a stage, first click on it on the animation board. Then select Cel from the toolbox and Delete from the selection box that appears. Click on OK in the warning box. The element is deleted from your frame.
Palettes

The Palettes option lets you modify the colors in any of the 16 palettes available for your film. Each palette contains 16 colors. In the Design menu, click on Palettes. The palette editor appears. *Film Director*'s palette editor is very similar to the palette editor in *Art Director*.

![Palette Editor Diagram]

Tip: Using the *Film Director* palette editor modifies the palette of Picture A only.

**Paintbox** The colors shown in the paintbox are the colors currently in your palette. The colors are numbered as they appear in the palette from top to bottom. Colors 0 through 3 are in the far left column of the palette; colors 4 through 7 are in the center left column; colors 8 through 11 are in the center right column; and colors 12 through 15 are in the far right column. The arrow marks the color currently showing in the color mixer.

**Color Mixer** Use the color mixer to modify the colors in your palette. You can change one color at a time in the color mixer. The color currently selected is shown in the color mixer.

To change a color in the mixer, move the cursor onto an empty square in the RGB grid and click. The square will be highlighted and the color in the color bar will change, reflecting the new RGB value you just set. The same color in the paintbox also changes to the new color. When you return to the animation board, the new color appears in the palette in place of the original color.

Tip: Do not set colors 0 and 15 to the same RGB value, or you will not be able to read the palette editor.
Palette Selector  In the palette selector, the 16 palettes available for your film are labeled A through P. Click on a palette letter to select it. The letter of the palette currently selected is highlighted, and the colors of that palette appear in the paintbox.

Copy  This selection copies colors. Use Copy to move colors around within a palette, or from palette to palette.

To copy a color within the same palette, first click on the color you want to copy in the paintbox. Then click on Copy. Finally, click on the color in the paintbox you want to copy over. The first color selected in the paintbox is copied over the second color.

To copy a palette, select a letter in the palette selector. Then click on Copy. Finally, select a second letter in the palette selector. The colors in the first palette selected will be copied onto the second palette selected.

Tip: To deselect Copy, click on it again.

Swap  This selection exchanges colors within a palette or from palette to palette.

To exchange colors in the same palette, select a color from the paintbox. Then click on Swap. Move the cursor back to the paintbox and select a second color to exchange with the first color. The two colors will trade places in the paintbox.

To exchange the colors of two palettes, first select a letter in the palette selector. Then click on Swap. Finally, select a second palette letter. The colors of the two palettes will be swapped.

Tip: To deselect Swap, click on it again.

Invert  When you click on this selection, it inverts all colors on the palette. Inverting a color changes it to its complementary color—one that has the opposite RGB value. (The new RGB value will be the old RGB value subtracted from 15,15,15.)

View Frame  Lets you look at your current frame in color or monochrome. To view it in color, move the cursor to the upper right quadrant of the View square and hold down the mouse button. To view it in shades of gray, move the cursor to the upper left quadrant and hold down the mouse button. Release the mouse button to return to the palette editor.

View Picture  Lets you look at your current picture in color or monochrome. To view it in color, move the cursor to the lower right quadrant of the View square and hold down the mouse button. To view it in shades of gray, move the cursor to the lower left quadrant and hold down the mouse button. Release the mouse button to return to the palette editor.
Undo  Click on Undo to cancel the last action you took in the palette editor.

After making your selections, click on OK to return to the animation board.

Editor

Selecting Editor puts you in Edit mode, with Edit as the third menu bar selection from the left. For complete information, see the previous section, Edit Menu Options.

Options Menu Options

The Options menu includes options for controlling the on-screen components, erasing frames, scripts, and pictures, and previewing an animated film.

Border Colors

The Border Colors option lets you change the color of the border surrounding your animation board. Select the option, then click on the color you want for the border. Click on OK or press Return to return to your animation board.
Display Tools

The Display Tools option lets you toggle certain screen displays on and off. Select the option to see its selection box:

Message  Selecting On displays the message line at the bottom left of the animation board. Selecting Off hides it.

Coord  Selecting On displays your cursor coordinates at the bottom right of the animation board. Selecting Off hides them.

V Scale  Selecting On displays a vertical scale on the animation board. The longer marks on the scale are spaced five pixels apart. To move the scale, place the cursor at the bottom of the scale, hold down the mouse button, and drag the scale left or right. Selecting Off hides the scale.

H Scale  Selecting On displays a horizontal scale on the animation board. The longer marks on the scale are spaced five pixels apart. To move the scale, place the cursor at the far left of the scale, hold down the mouse button, and drag the scale up or down. Selecting Off hides the scale.

Make your selections and click on OK or press Return.

Free Cursor

The Free Cursor option lets you free your cursor to move off the visible animation board. Selecting Restrict Cursor restricts your cursor movement to the visible board area.
Hide Messages

When you select Hide Messages, all display tool messages are hidden. To show the items that are on in the Display Tools selection box, select Show Messages from the Options menu.

Hide Toolbox

Select the Hide Toolbox option to remove the toolbox from the screen. To show the toolbox again, select Show Toolbox from the Options menu.

Erase Frames

This option is available when Edit is the third menu bar selection from the left. Select Erase Frames to erase the frames currently in memory, but leave intact all film elements (patterns, polygons, groups, actors, stages, and palettes).

Using Erase Frames you can create a new film with those previously defined elements, as well as palettes and pictures.

Tip: Once a series of frames is erased, it cannot be recalled unless it has been previously saved to disk as a film file.

Erase Script

This option is available when Design is the third menu bar selection from the left. Select Erase Script to erase all patterns, polygons, groups, actors, stages, and frames in memory, but leave intact the palettes and pictures.

Using Erase Script you can begin defining new film elements with existing pictures and palettes.

Tip: Once a script is erased, it cannot be recalled unless it has been previously saved to disk as a script file or as part of a film file.

Erase Picture

The Erase Picture option is available when Design is the third menu bar selection from the left. It lets you erase a picture from memory.

When you select Erase Picture, its selection box appears listing the pictures in memory. Click on the picture you want to erase, then click on erase or press Return to delete the picture. If you've cut a pattern out of the picture, it becomes a blank pattern in memory.

Tip: Once a picture is erased, it cannot be recalled unless it has been previously saved to disk as an art file or as part of a film file.
Show Film

Select the Show Film option to view the animated film currently in memory. When you click on the option, its selection box appears.

Direction: Select Back or Forward to run your film in the reverse or forward direction.

Speed: Indicates the speed at which your films will be shown. Speed 1 is the slowest; speed 9 is the fastest. Select Slower or Faster to change the number (or type in the number of the speed you want).

After making your selections, click on OK or press Return. The film will begin to play.

During a show, click to freeze a film at the last frame displayed. The Frame toolbox appears, and you can edit the frame. In this way you can use Show Film to find an incorrect frame and edit it.

Using Film.Show

Film.Show lets you show your animated films. To do that, insert the disk containing the Film.Show program into a drive and run the program.

Film.Show first searches for the file DemoFilm and runs that film. If DemoFilm is not in the same directory as Film.Show, the program displays a menu bar with two items: Apple and File. Display the File menu and select Load Film. Select the film you want to load from the item selector that appears. When you click on OK, Film.Show loads and shows the selected film.

During the film, press the Left Arrow to watch your film in reverse. Press the Right Arrow to return to forward showing. Press the Down Arrow to slow the film; press the Up Arrow to speed it up. Press Spacebar to pause the film; press it again to advance one frame. Press any key to resume the show. Press Esc or click the mouse button to stop the film and return to the menu bar.

Select Show Film from the File menu to see a selection box offering direction and speed options. Use this selection box the same way you use the Show Film selection box while working in Film Director.

Select Quit from the File menu and click on Yes in the dialog box that appears to exit the program.
Using Music.Selector

_Film Director_ can load one music file at a time containing up to nine sounds that you can add to your animated films. The _Film Director_ disks contain three music files, for a total of 27 sounds for you to choose from. The music selector program Music.Selector lets you assemble your own music files by choosing sounds from three existing files.

1. Insert the disk containing the program Music.Selector and the music files into a drive. Select Music.Selector by clicking on its icon and then clicking on Open. The program loads and displays a menu bar with two options: Apple and File.

2. Select the Load Music option from the File menu. An item selector appears listing the music files, called Music.1, Music.2, and Music.3. Select the file you want by clicking on its icon. This will be your input file. Click on Open.

3. An edit box appears showing the nine sounds in the file with the numbers 1 through 9.

4. To preview a sound from the input file, click on a number, then click on Play. (To stop a sound before it finishes, click again.)

5. To add a sound from the input file to your output (custom) file, move the cursor to the number of the sound you want. Hold down the mouse button and drag the sound to a location (from 1 through 9) in the output file. Release the mouse button. If the sound is where you want it, click on OK in the dialog box that appears. If not, click on Cancel.

Tip: You can preview the sounds in the output file by selecting a sound number and clicking on Play.

6. To cancel all selections, select Cancel in the edit box, then click on Yes. Doing this cancels all changes you made since entering the edit box.

7. When you finish moving sounds from the input file to the output file, click on OK.

8. To copy sounds from a second input file to your output file, select Load Music from the File Menu and load another input file. Copy the sounds you want, then click on OK. Select Edit Music from the File menu if you need to make changes.

9. To save your output file, click on OK in the edit box. Then select Save Music from the File menu. In the item selector that appears, type a filename for your file in the Save Music box. When you click on Save, the file is saved to your disk in the drive.

Select Quit from the File menu and click on Yes in the dialog box that appears to exit the program. The File menu also contains the Delete File and Format Disk options. Use them in the same way you use the Delete File and Format Disk options in _Art Director_.

121
Taping Your Art and Films

Once you've created artwork or animated films using Art & Film Director, you can record your work on video tape.

Cabling
1. Plug one end of an RCA phono cable (a cable with male RCA jacks on both ends) into the female RCA jack on your computer, which is the composite video port.

2. Plug the cable's other end into the Video In jack on the VCR. If the female In jack is not an RCA jack, insert an adapter between the cable and the Video In jack. (For example, some VCRs require an RCA to BNC adapter.)

Recording

To record your Art & Film Director work, follow these steps.

1. Insert the tape you want to use for recording into your VCR.

2. Prepare your VCR for recording by starting to record and then immediately pausing the VCR. (See your VCR manual for instructions.)

3. Load whatever you want to record into Art Director, Film Director, Art.Show, or Film.Show. If you're recording an animated film, begin by showing the film, then immediately pause it.

4. Unpause the VCR (and the animation if recording a film).

5. When you've finished recording, stop or pause the VCR. (If you're going to record other pictures or films, it's better to pause the VCR rather than stop it.)

Tip: When recording from Art Director, turn your display off by clicking on Display in the toolbox. It is often most effective to tape your work from Film.Show and Art.Show.
FILM DIRECTOR
KEYBOARD SHORTCUTS

With Film Director, you can make selections from the keyboard instead of using your mouse. Press the following keys to select the option listed next to each key.

General Use

D or Open Apple M  Toggles Message on/off.
M                    Toggles menu bar on/off.
R                    Toggles Restrict Cursor/Free Cursor.
Open Apple or Control or Esc  Displays control panel.
Arrow keys   Generally move cursor one pixel in arrow's direction.
Open Apple Arrow keys Generally move cursor eight pixels in arrow's direction.
Option        Constrains cursor to vertical movement when using the mouse.
Shift         Constrains cursor to horizontal movement when using the mouse.

File Menu

Press these keys to select options from the File menu.

Open Apple L  Load Film (while in Edit mode)
Open Apple S  Save Film (while in Edit mode)
Open Apple C  Load Script (while in Design mode)
Open Apple I  Load Picture (while in Design mode)
Open Apple Q  Quit
Edit Menu

Press these keys to select options from the Edit menu.

Open Apple F  Frames
Open Apple V  Sequence
Open Apple E  Designer

Design Menu

Press these keys to select options from the Design menu.

Open Apple 1  Patterns
Open Apple 2  Polygons
Open Apple 3  Groups
Open Apple 4  Actors
Open Apple 5  Stages
Open Apple 6  Palettes
Open Apple E  Editor

Options Menu

Press the following keys to select options from the Options menu.

Open Apple B  Border Color
Open Apple 0  Hide Toolbox/Show Toolbox
Open Apple W  Show Film
**Music.Selector**

Press these keys to select options while running the program Music.Selector.

- **Open Apple L** Load Music
- **Open Apple S** Save Music
- **Open Apple E** Edit Music
- **Open Apple D** Delete File
- **Open Apple Q** Quit

**Film.Show**

Press these keys to select options while running the program Film.Show.

- **Open Apple L** Load Film
- **Open Apple S** Show Film
- **Open Apple Q** Quit
- **Left Arrow** Show film backward
- **Right Arrow** Show film forward
- **Up Arrow** Increase speed by one number
- **Down Arrow** Decrease speed by one number
- **Spacebar** Freeze film at current frame or advance to next frame
- **Esc** Stop film
FILM NOTES