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1. Introduction
The Cortland Finder is a combination Program Selector / Disk Utility
package for managing documents and directing· traffic between the user
and storage devices. The Finder provides disk utilities for ProDOS 1.2
ProDOS16 v1.0 and 2.0, DOS 3.3 Apple CP/M and Pascal 1.3. Minimal
printing support is provideq, as well as the ability to launch ProDOS based
applications.
Because of the tight development schedule for the Finder, several features
had to be left out of this version. Just because something isn't in this
version doesn't mean it won't ever be a part of the Finder. It just won't
happen before September.

Overview:
Common Finder tasks include:
• opening, closing, copying, discarding, moving, and renaming
applications, documents and disks.
• organizing documents on the desktop, in folders, and on disks.
• initializing disks.

What the Finder Manages:
Applications and Documents:
Applications and documents are represented in their closed state as icons.
The user can rename, duplicate, discard, and organize applications and
documents on disks and in folders.
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Disks:
The contents of a disk are displayed in a directory window. Each disk can
contain documents, applications, and folders. Usually each item is
represented by an icon the user can select and drag; you can choose to see
the disk's contents arranged in other ways with the View menu.
Disks currently inserted and recognized by the system will appear as
white disk icons. The icon becomes hollow when its window is opened.
Icons for disks that have been removed from the drive appear dimmed in
grey. (80th inserted and ejected disk are highlighted when selected.) The
Finder will remember the contents of disks inserted and then removed.
Ejected disks (or any folders contained in them) can be opened into
directory windows, any items on ejected disks also appear dimmed. You
can manipulate dimmed icons just like white icons. The Finder will ask
you to reinsert the disk when it needs it.
Folders:
Folders allow you to arrange your applications and documents
hierarchically on a disk. Folders are equivalent to ProDOS sUbdirectories.
Folders are not supported on DOS 3.3, CP/M or Pascal volumes. When
opened, folders display their contents in a directory windows just like
disks. Folders can contain other folders.
Desktop:
The desktop in the finder is a temporary resting place for icons. If you're
concentrating on only a few documents and applications at a time, and
they're on different disks or in different folders, you can drag all the
documents to the desktop and work on them there. You can even close the
windows for the folders and disks they came from; the finder will
remember where the documents belong.
Documents are automatically put back when you open a document or
application.
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Trash:
The Trash is a receptade for discarding documents and folders. The finder
will eject a disk when its icon is dragged into the Trash. When the icons
for a disk II or hard disk is dragged into the trasgh, the icon will disapear.
The only way to get the finder to recognize the disk again is to use the
Check Drives option from the specail menu. When you discard a folder, the
folder and its entire contents disappear. Locked documents can't be
discarded; you must unlock them (in their information window) before
discarding.
The Trash for the Cortland Finder behaves very differently than in
Macintosh versions of the Finder.
Items placed in the trash are never deleted without some action from the
user. This is substantially different from the Macintosh where items may
be purged without warning. Items in the trash are deleted if the user
selects Empty Trash from the Special Menu. If there is insufficient room
on the disk for an operation to be performed a dialog box will appear
asking the user if the items in the trash may be deleted.
Under ProDOS, placing an item in the trash is equivalent to changing the
pathname of the item to NrrRASHIitem.
On DOS and Pascal volumes. a file named TRASH is created. This file
contains the name~ of a the items in the trash.
Selecting Icons:
Once an icon is selected, the Edit menu commands operate on that icons's
name and the File menu commands operate on what the icon represents.
When more than one icon is selected, the Edit menu commands are dimmed.
A group of icons may be selected only if they're all in the same window or
all on the desktop. If you want to work on a number of documents in
different folders or disks, drag them to the desktop and select them all
there.
Operations on a group of icons are performed one by one. The icons are
taken in order form left to right, top to bottom.
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Dragging Icons:
Dragging an icon from one place to another moves that icon to the new
place. You can drag an icon onto the desktop, onto a folder, disk or Trash
icon, or onto an open folder, disk, or Trash window.
Dragging an icon from one place to another on the same disk (or to a folder
on the same disk) merely moves the icon to the new place (note that the
corresponding path name of the file may change). Dragging an icon to
another disk (or to a folder on that disk) leaves a copy behind on the
original for safekeeping. If you don't want the copy left behind on the
original, just hold down the option key while dragging the icons.
If you drag an icon to another disk, and there's already an icon with that
same name on that disk, you're asked if you want to replace it with the
icon you're dragging.

Drag document

Drag folder

Drag application

to folder on
same disk

moves it there

moves it there

moves it there

to folder on
different disk

copies it there

copies it and its
contents there

copies it there

to a different
disk

copies it there

copies it and its
contents there

copies it there

to Trash

discards it

discards it and
its contents

discards it

Drag disk

copies it there

• In general, dragging an icon on the same disk moves it; dragging an icon
to a different disk copies it.
•
• To make an extra copy on the same disk, use the Duplicate command in
the File menu.
• You can drag an icon to another disk's icon or to that icon's window; the
effect is the same, although dragging into a window lets you drag to a
specific location in the folder or disk window.
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• You can drag locked documents, you can't drag anything to or from a
locked disk.

Finder Menus:
The Apple Menu
About the Finder:
Show a tasteful dialog containing the version number and authors of the
finder.
Desk Accesories:
Choosing any of the desk accessories causes that accessory to appear on
the desktop. You can use the Edit menu to cut, copy, and paste the
information in most desk accessories. The desk accessory stays on your
desktop until you close it, with either the close box or the Close command
in the File menu.
The only desk accessory currently planned for the Finder is a Control
Panel. This graphic control panel will provide the functionality of the
rom-based control panel while providing a mouse/window interface.

The File Menu
The commands in the file menu operate on icons and windows.
New Folder:
Creates a new folder named Empty Folder. If there is already an item
named EmptyFolder then the new folder will be named EmptyFolder1 .
Open:
Opens the selected icon into a window. If the icon represents a document,
opening may also start an application so you can work on the document. If
the icon represents an ProDOS application, opening it will launch the
application.
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Print:
Will display a standard file type dialog asking for a file to be printed. The
path name of that file will then be passed, to the Finder's print driver.
Close:
Will close the currently active window or disk accessory. This is
equivalent to clicking in the close box of the window.
Get Info:
Opens a window that displays information about whatever the selected'
icon represents: The displayed information includes its size, kind (file
type), the date it was created, the date it was last changed, and which
disk or folder it belongs to. You can still drag or open a selected icon while
its information window is open.
Duplicate:
Duplicates the selected items on the same disk. The duplicates are named
Ifile1" where file is the name of the item duplicated. Duplicating the item
again will create a duplicate named "file2".
Duplicating a folder duplicates the folder and all of its contents. Note that
duplicating a folder changes the name of the duplicate folder, not the
names of the applications in that folder. Duplicating a folder named Fred
will create a folder named Fred1. The names of the files in Fred1 will be
the same as those is Fred.

The Locked check box allows you to lock a document or application. When
the Locked box is checked, that document or application can't be disposed
of and its name can't be changed. It can, however, be modified in any other
way.
Put Away:
Will return an icon on the desktop on to the icon's home window.
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Page Setup:
Displays a dialog that allows the user to configure the way the Finder
prints things.
Print Catalog:
Will print a the catalog of the currently active disk or folder. Note that the
output is formatted according to the view menu.
Eject:
Will cause the selected 3.5" disk to be ejected. Note that only 3.5" disks
will be physically ejected from the drive. 5.25" disks will be treated as if
they had been dragged into the trash.

The Edit Menu
The Finder's Edit menu allows you to edit:
• The names of icons
• Text in an information window (opened by selecting the icon and
choosing Get Info from the File menu)
• text or pictures in desk accessories. '
You cannot use this menu to cut or copy icons. Icons are moved by dragging
~em.
.
Support for features of the Edit menu is based on the current design for a
Mac-like Scrap Manager. The Scrap Manager handles cutting and pasting to
the desktop. The Scrap Manager will support transfering text and Quick
Draw pictures.
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Selecting an icon also selects the text below it. Anything sUbsequently
typed replaces the old text. Clicking the text itself causes an insertion
point to appear. This text can be edited in the normal fashion.
Undo:
Undoes your last text-editing action in a desk accessory.
Cut:
Removes the selection and placed in on the Clipboard, replacing the
previous contents if any.
Copy:
Places a copy of the selction on the Clipboard, replacing the previous
contents if any.
Paste:
Puts a copy of the contents of the Clipboard at the insertion point. You can
continue to paste copies until you cut or copy a new selection, which
replaces the old contents of the clipboard.
Clear:
Removes the selection, without placing it on the Clipboard.
Select All:
Selects all icons in the active window.
Show Clipboard:
Displays a window with the current contents of the Clipboard -- that is,
whatever you cut or copied.
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The View Menu
The commands in the view menu'let you view the directories of disks,
folders, or the Trash in other arrangements. When the arrangement is other
than pictorial, you select by clicking on a name rather than an icon.
The current view of the active window is marked in the View menu by a
check.

By Small Icon:
Shows the contents of a directory window as small icons with the name of
the icon displayed on the right side of the icon.
By Icon:
Shows the contents of a directory window as icons, just as on the desktop.
By Name:
Lists the contents of a directory window alphabetically by name.
By Date:
Lists the contents of a directory window chronologically by modification
date. The document most recently modified is listed first.
By Size:
Lists the contents of a directory window by size, largest first. Useful for
seeing which of your documents are taking the most room on the disk.
Folders are listed according to their contents.
By Kind:
Lists the contents of a direc'tory window by kind ie. by file type.
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The Special Menu
Clean Up:
Used only in By Icon view. Arranges all icons in the frontmost window in
neat rows and columns. If no directory windows are open, Clean Up cleans
up the desktop.
Empty Trash:
Removes the contents of the Trash. Files placed in the Trash are deleted.
Erase Disk:
Initializes (and completely erases) the disk whose icon is selected. You
can't erase the startup disk because the Finder needs the information on
that disk in order to work. If you want to erase a certain disk, start
Cortland using a different disk, eject that disk if necessary and insert the
disk you want to erase.
When a disk is erased it will always be reformatted using the operating
system that was originally on that disk. In order to reformat a disk using a
different operating system, use the format command.
Check Drives:
Will cause the Finder to check all of the disk drives and display any disks
found on the desktop. This is the only way to get a 5.25" disk to appear on
the desktop.
.
Format Disk:
Will cause the Finder to display a dialog box allowing the user to select a
disk device and an operating system to be used for formatting the disk.
Set Startup:
Lets you jump immediately into the application whose icon is highlighted
whenever you start your cortland asing that disk. You can reset the startup
to the Finder by selecting the Finder icon and choosing set startup again.
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Operating Systems Supported:
The Cortland Finder will recognize disks formatted under the following
operating systems:
• ProDOS/16
• ProDOS/8
• Pascal 1.3 .
• DOS 3.3
• Apple CP/M
• Mac MFS
• Mac HFS
Llmitations on Operating Systems:
Eventually, the Finder will probably support all Apple operating systems.
In version 1.0 the primary support is for ProDOS volumes. Support for DOS
Pascal, and CP/M volumes will be provided as time allows and will be
limited to the level of support provided in the System Utilities. In addition
there are certain limitations enforced by the structure of some of the
operating systems that might limit the functionality of the Finder. All
features of the Finder may not be availible on all disks.
DOS 3.3:
The title of a directory window from a DOS 3.3 volume in slot 6, drive 1
will be DOS 3.3 -- S6,D1 . This is unavoidable since DOS doesn't support
volume names. The Finder will not allow the user to edit the name of a DOS
volume.
Mac File System and Mac HFS:
Macintosh disks are supported to the extent that the Finder will recognize
a Mac disk. When the Finder detects a Mac disk in"the driver it will display
a dialog box with a message such as: "This is a Macin~osh Disk -- Do You
Want to Format It". Future versions of ·the Finder may allow for file
transfer to and from Macintosh disks.
Note that folders are supported only on ProDOS volumes.
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Launching and Quiting Applications:
ProDOS applications can be launched either by double-clicking on the
associated icon or by selecting the icon and choosing open from the File
Menu. The Finder patches the ProDOS quit code; when the user quits from
an application the Finder will be reloaded and executed.
When the user tries to launch an application from a DOS 3.3, Pascal or
CP/M volume, the disk is booted. The user can the launch the application
from that operating systems native environment. There is also no way to
quit from a DOS 3.3 or Pascal application. The user will have to reboot the
Cortland to return to the Finder. Future versions of the Finder may allow
the user to boot applications individually from Pascal qr DOS disks.

Copying Files Between Different Operating Systems.
Ideally, the user will be able to copy files from one operating system to
another simply by dragging the file's icon to another disk. When copying
files between different operating systems, the Finder will try to convert
the file. This mayor may not do anything useful. For example, a Pascal
code file may be copied to a ProDOS-16 disk. Its doubtful that the program
would run. Of course, copying a DOS 3.3 based Applesoft program to a
ProDOS-8 disk may result in an executable program.
The conversion routines used will be identical (read stolen) from the
system utilities., Additional functionality will not be availible in the first
release.
Different Size Volumes
When doing a volume copy (ie. dragging a disk icon onto another disk's icon,
it is possible that the volumes will not be the same size. This might occur
when copying the contents of a 5 1/4" disk to a hard disk. The copy will be
permitted if the destination volume is larger than the source volume. In
any other case an appropriately tasteful dialog box.
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Icons
There will be default icons for most of the common file types supported on
under the various Apple II operating systems. This default icons will
allow probably be availible for the following:
ProDOS-8:
• System
• Text
• Binary
• Basic
ProDOS-16
• System
• Text
• Binary
• Basic
Pascal 1.3
• Code
• Text
• Data
DOS 3.3
• Code
• Text
• Applesoft
Additional file types can be recognized if necessary and appropriate.
This document doesn't address what the default icons for the system will
look like. Once these are created, I will add them to the document. User
defined icons will be discussed another document. They will be support
only for ProDOS 16 files supporting the new load module format.
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Printing From the Finder:
There will be an icon on the desktop for character I/O devices such as
printers, if installed. The user will be able to print a document by dragging
it over to the printer icon (same as copying it). Note that this will print
the document in draft mode. A word processor file may also contain funny
formatting characters that might affect the printer. I'm not really sure
how to handle all of the different file types yet.
Note: this is on the list of things to drop if we run short on time.
Ram Disk Support:
The Finder will support the ram disk much in the way that the Macintosh
Finder supports its ram disk. An icon will appear for the ram disk if it is
installed in the smart port chain (slinky cards in a slot are recognized
too!). The Finder will then treat the ram disk like any other disk drive.
I am strongly opposed to adding Catalyst/Mouse Desk style ram disk
support. Automatically copying files to the ram disk has several problems.
One of the major ones is that it takes forever to load the Finder and all of
the applications onto the ram disk. We'll probably have enough speed
problems on Cortland as it is.
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