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1. Introduction

The Cortland Finder is a combination Program Selector I Disk Utility
package for managing documents and directing traffic between the user
and storage.devices. The Finder provides disk utilities and application
launching for ProDOS 1.2 and ProDOS16 versions 1.0 and 2.0.

Because of the tight development schedule for the Finder, several features
had to be left out of this version. Version 2.0 of the Finder will be
released at the same time as ProDOS 16 v2.0 (probab~y in early 1987). This
version will be more exstensive.

Overview:

Common Finder tasks include:

• opening, closing, copying, discarding, moving, and renaming
applications, documents and disks•

• organizing documents on the desktop, in folders, and on disks.

• initializing disks•

.
What the Finder Does:

The Finder aJlows the user to work with files and disks in manner that is
much easier than before. The types of items the user can work with in the
Finder are:

Applications and Documents:

Applications and documents are represented in their closed state as icons.
The user can rename, duplicate, discard, and organize applications and
documents 'on disks and in folders.

J. Worthington Apple CONFIDENTIAL . page:2



Disks:

The contents of a disk are displayed ina directory window. Each disk can
contain documents, applications, and folders. Usually each item is
represented by an icon the user can select and drag; you can choose to see
the disk's contents arranged in other ways with the View menu.

Disks currently inserted'and recognized by the system will appear as
white disk icons. The icon becomes hollow when its window is opened.
Icons for disks that have been removed from the drive appear dimmed in
grey. (Both inserted and ejected disk are highlighted when selected.) The
Finder will remember the contents of disks inserted and then removed.
Ejected disks (or any folders contained in them) can be opened into.
directory windows, any items on ejected disks also appear dimmed. You
can manipulate dimmed icons just like white icons. The Finder will ask
you to reinsert the system disk when necessary.

Folders:

Folders allow you to arrange your applications and documents
hierarchically on a disk. Folders are a representation of ProDOS
subdirectories. When opened, folders display their contents in directory
windows just like disks. The contents of a folder can be files and other
folders. Note that a folder cannot contain a disk.

Desktop:

The desktop in the finder is a temporary resting place for icons. If you're
concentrating on only a few documents and applications at a time, and
they're on different disks or in different folders, you can drag all the
documents to the desktop and work with them there. You can even close
the windows for the folders or disks th_y came from; the finder will
remember where the documents belong.

Documents are automatically put away when you open a document or
application.
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Trash:

The Trash is a receptacle for discarding documents and folders. The finder
.:.~~/ will eject a disk when its icon is dragged into the Trash. When the icon

for a disk /I is dragged into the trash, the icon will disapear, but the disk
is not ejected•. The only way to get the finder to recognize the disk again
is to use the Check Drives option from the special menu. When you discard
a folder, the folder and its entire contents disappear. Locked documents
can't be discarded; you must unlock them before discarding. Locked items
can be unlocked hi their information window or in the warning dialog
displayed when you attempt to discard a locked item.

Items placed in the trash are never deleted without some action from the
user. This is substantially different from the Macintosh where items may
be purged without warning. Items in the trash are deleted jf the user
selects Empty Trash from the Special Menu. If there is insufficient room
on the disk for an operation to be performed, a dialog box will appear
asking the user if the items in the trash may be deleted.

Placing an item in the trash is equivalent to changing the pathname of the
item to NITRASHlitem, where V is the name of the ProDOS volume.
Because the trash is stored as a ProDOS subdirectory, it can be
manipulated using normal ProDOS utilities as well as the finder.

Selecting Icons:

Once an icon is selected, the Edit menu commands operate on that icon's
name and the File menu commands operate on what the icon represents.

When more than one icon is selected, the Edit menu commands are dimmed.

A group of icons may be selected only if they're all in the same window or
all on the desktop. If you want to work on a number of documents from
different folders or disks, drag them to the desktop·and select them all
there. .

Operations on a group of icons are performed one by one. The icons are
taken in order from left to right, top to bottom.
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Dragging Icons:

Dragging an icon from one place to another moves that icon to the new
place. You can drag an icon onto the desktop, a folder, a disk or the Trash
icon. You can also drag an icon into the window corresponding to an open
folder, disk, or Trash window.

Dragging an icon from one place to another,on the same disk (or into a
folder on the same disk) merely moves the icon 'to the new place. Note that
the ProDOS path name of the file will change if it was dragged to or from a
folder. Dragging an icon to another disk copies the file to the new disk,
leaving a copy behind on the original for safekeeping. If you don't want the
copy left behind on the original, hold down the option key while dragging
the icons.

If you drag an icon to another disk, and there's already an icon with that
same name on that disk, you're asked if you want to replace it with the
icon you're dragging.

Oragdocument Drag folder Drag application Drag disk

to folder on moves it there moves it there moves it there
same disk

to folder on copies it there copies it and its copies it there
different disk contents there

to a different copies It there copies it and its copies it there copies it there
disk contents there

to Trash discards It discards it and discards It
Its contents

>

• In general, dragging an icon anywhere on the same disk moves it;
dragging an icon to a different disk copies it

• To make an extra copy of a file on the same disk, use the Duplicate
command in the File menu.

• You can drag an icon to another disk's icon or t() that icon's window; the
effect is the same, although dragging into a window lets you drag to a
specific location in the folder or disk window.
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• You can drag locked documents from disks to other disks. You can't drag

anything to a locked disk.

\".~.

Finder Menus:

The Apple Menu

About the Finder:

Show a tasteful dialog containing the version number and authors of the
finder.

Desk Accesories:

Choosing any of the desk accessories causes that accessory to appear on
the desktop. You can use the Edit menu to cut, copy, and paste the
information in most desk accessories. The desk accessory stays on your
desktop until you close it, with either the close box or the Close command
in the File menu. Classic Desk AccesSories can be activated from the
Finder by presing Control· Open Apple· Reset

..~., Desk Accessories are part of the Cortland system software. The curious
(and/or brave) should see "The Desk Manager ERS" by Steve Glass and John
Worthington for an in depth discussion of desk accesories.

The file Menu

The commands in the file menu operate on icons and windows.

New Folder:

Creates a new folder named EMPTYFOLDER. If there is already an item
named EMPTYFOLOER then the new folder will be named EMPTYFOLDER1.

Open:

Opens the selected icon into a window. If the icon represents an ProDOS
application, opening it will launch the application. ProDOS Applications
are files of type SYS, SYS16, and BIN.

i
\.

,..",
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Close:

Will close the currently active window or desk accessory. This is
functionally equivah~nt to clicking in the close box of the window.

Get Info:

Opens a window that displays information about whatever the selected
icon represents. The displayed information includes its size, kind (file
type), the date it was created, the date it was last changed, and which
disk or folder it belongs to. You can still drag or open a selected icon while
its information window is open.

The Locked check box allows you to lock a document or application. When
the Locked box is checked, that document or application can't be disposed
of and its name can't be changed. It can, however, be modified in any other
way.

Note that the Cortland Finder differs from the Macintosh Finder in that
there is no text box for user comments. This might be added in version 2.0.

Duplicate:

Duplicates the selected items on the same disk. The duplicates are named
Rfile1" where file is the name of the item duplicated. Duplicating the item
again will create a duplicate named "file2". If appending a number would
cause the length of the file name would exceed the 15 character limit, the
15th character will be replaced by the number. For example,
AREALLYLONGFILE would become AREALLYLONGFIL1.

Duplicating a folder duplicates the folder and all of its contents. Note that
duplicating a folder changes the name of the duplicate folder, not the
names of the applications in that folder. Duplicating a folder named FRED
will create a folder named FRED1. The names of the files in FRED1 will be

. the same as those is FRED.
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Put Away:

Will return an icon on the desktop to the icon's home window.

Eject:

Will cause the selected 3.5" disk to be ejected. Note that only 3.5" disks
will be physically ejected from the drive. 5.25" disks will disappear from
the desktop, although the disk remain in the drives.

The Edit Menu

The Finder's Edit menu allows you to edit:

• The names of icons

• text or pictures in desk accessories.

You cannot use this menu to cut or copy icons. Icons are moved by dragging
them.

Support for features of the Edit menu is based on the current design for a
Mac-like Scrap Manager. The Scrap Manager handles cutting and pasting to
the desktop. The Scrap Manager will support transfering text and Quick
Draw pictures.

Selecting an icon also selects the text below it. Anything subsequently
typed replaces the old text. Clicking the selected text itself causes an
insertion point to appear. This text can then be edited in the normal
fashion.

Undo:

Undoes your last text-editing action in a desk accessory.

Cut:

Removes the selection and places it on the Clipboard, replacing the
previous contents if any.
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Copy:

Places a copy of the selection on the Clipboard, replacing the previous
contents if any.

Paste:

Puts a copy of the contents of the Clipboard at the insertion point You can
continue to paste copies until you cut or copy a new selection, which
replaces the old contents of the clipboard.

Clear:

Removes the selection, without placing it on the Clipboard. The contents of
the clipboard are intact.

Select All:

Selects all icons in the active window.

Show Clipboard:

Displays a window with the current contents of the Clipboard -- that is,
whatever you cut or copied.

The View Menu

The commands in the view menu let you view-the directories of disks,
folders, or the Trash in other arrangements. When the arrangement is other
than pictorial, you select by clicking on a name rather than an icon.

The current view of the active window is marked in the View menu by a
check.

by Icon:

Shows the contents of a directory window as icons, just as on the desktop.
This"is the default for the Finder.
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by Name:

Lists the contents of a directory window alphabetically by name.

by Date:

Lists the contents of a directory window chronologically by modification
date. The document most recently modified is listed first

by Size:

Lists the contents of a directory window by size, largest first. Useful for
seeing which of your documents are taking the most room on the disk.
Folders are listed according to· their contents.

by Kind:

Lists the contents of a directory window by kind ie. by file type.

The Special Menu

Clean Up:

Used only in By Icon view. Arranges all icons in the frontmost window in
neat rows and columns. If no directory windows are open, Clean Up cleans
up the desktop.

Empty Trash:

Removes the contents of the Trash. All Files placed in the Trash are
deleted.

Erase Disk:

Initializes (and completely erases) the disk whose icon is selected. You
can't erase the startup disk because the Finder needs the information on
that disk in order to work. If you want to erase a certain disk, start
Cortland using a different disk, eject that disk if necessary and insert the
disk you want to erase.
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Check Drives:

Will cause the Finder to check all of the disk drives and display any disks
found on the desktop. This is the only way to get a 5.25" disk to appea,r on
the desktop.

Format Disk:

Will cause the Finder to display a dialog box allowing the user to select a
disk device to be formatted. This is the only way to format 5.25" disks
since the Finder can't tell whether or not an un-initialized 5.25" disk is in
a drive.

Operating Systems Supported:

The Cortland Finder will recognize disks formatted under the following
operating systems:

- ProDOSl16
- ProDOS/S
- Pascal 1.3
- DOS 3.3
-Apple CP/M
- Mac MFS
-MacHFS

Umitations on Operating Systems~

Eventually, the Finder will probably support all Apple operating systems in
some reasonable manner. In version 1.0 support is provided for ProDOS
volumes only. The System Utilities will be provided on the Finder disk and
can be used for DOS 3~3, Pascal, and CP/M disks as well as ProDOS.
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Trivia:

Launching and QtJiting Applications:

ProDOS applications can be launched either by double-clicking on the
associated icon or by selecting the icon and choosing open from the File
Menu. When the user quits from the application the Finder will be reloaded
and executed.

Copying Different Size Volumes:

When doing a volume copy (ie. dragging a disk icon onto another disk's icon,
it is possible that the volumes will not be the same size. This might occur
when copying the contents of a 51/4· disk to a hard disk. The copy will be
permitted if the destination volume is larger than the source volume. In
any other case an appropriately tasteful dialog box will appear to confirm
that you want to perform a file copy of all files rather than a volume copy.

Icons:

There will be default icons for most of the common file types supported on
under the various Apple /I operating systems. See appendix A. for a list of
icons included with the Finder•.

Printing From the Finder:

Version 1.0 of the Finder provides no support ~or printing.

Ram Disk Support:

The Finder will support the ram disk much in the way that the Macintosh
Finder supports its ram disk. An icon will appear for the ram disk if it is
installed in the smart port chain (slinky cards in a slot are recognized
tooI). The Finder will then treat the ram disk like any other disk drive.
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Appendix A
Icon Types

We are currently planning to include the following icons with the finder.

Generic Document
Generic Application
System File
Binary File

. Program File (applesoft)
Font File
New Desk Accessory
Classic Desk Accessory
Word Processor Application
Word Processor Document
Spreadsheet Application
Shreadsheet Document
Database Application
Database Document
Draw Application
Draw Document
Project Application
Project Document
Paint Application
Paint Document
Communications Application
Communications Document
Training Application
Training Document
Appleworks Database Document
Appleworks Spreadsheet Document
Appleworks Word Processort Document
CPW Source
CPW Object File
CPW Ubrary File
CPW Run Time Ubrary File
CPW Shell load File
ProDOS Init File (permanent)
ProDOS Init File (transient)
Tools
Clipboard
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